<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> 
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="language" content="en, sv" />
<meta name="viewport" content="width=device-width" /> 			<script type="text/javascript">
			var addToHomeConfig = {
			expire: 10000,
			touchIcon: true
		};
		</script>
		<link rel="stylesheet" href="https://theeasterner.org/wp-content/themes/snoflex/tools/addtohome/add2home.css">
		<script type="application/javascript" src="https://theeasterner.org/wp-content/themes/snoflex/tools/addtohome/add2home.js"></script>
		<meta name="apple-mobile-web-app-capable" content="yes">
	<link rel="apple-touch-icon" href="https://www.easterneronline.com.php53-12.ord1-1.websitetestlink.com/wp-content/uploads/2014/06/iPAD-Icon.jpg" /><link rel="Shortcut Icon" href="/wp-content/uploads/2014/06/Favicon.jpg" type="image/x-icon" />
<link rel="alternate" type="application/rss+xml" title="The Easterner RSS 2.0" href="https://theeasterner.org/feed/" />
<link rel="alternate" type="text/xml" title="The Easterner RSS .92" href="https://theeasterner.org/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="The Easterner Atom 0.3" href="https://theeasterner.org/feed/atom/" />

<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v16.1.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Baseball is Back! - The Easterner</title>
	<link rel="canonical" href="https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Baseball is Back! - The Easterner" />
	<meta property="og:description" content="&nbsp; The MLB season started on time this year, after last season was cut down to only 60 games due to COVID-19 and disagreements between the MLBPA and the MLB owners regarding contract modifications for the season.  The 2020 MLB season finally got underway on Jul. 23 after back-and-forth negotiations that finally ended with the..." />
	<meta property="og:url" content="https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/" />
	<meta property="og:site_name" content="The Easterner" />
	<meta property="article:publisher" content="https://www.facebook.com/TheEasterner/" />
	<meta property="article:published_time" content="2021-04-19T16:21:05+00:00" />
	<meta property="og:image" content="https://theeasterner.org/wp-content/uploads/2021/04/trevor-bauer-mlb-los-angeles-dodgers-main-image-MLB.png" />
	<meta property="og:image:width" content="1000" />
	<meta property="og:image:height" content="667" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@_theeasterner" />
	<meta name="twitter:site" content="@_theeasterner" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="By Michael Spearman, Reporter">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="5 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://theeasterner.org/#organization","name":"The Easterner - Eastern Washington University","url":"https://theeasterner.org/","sameAs":["https://www.facebook.com/TheEasterner/","https://www.instagram.com/the_easterner","https://www.youtube.com/channel/UC7frb25SSydY63DQPHWDdhw","https://twitter.com/_theeasterner"],"logo":{"@type":"ImageObject","@id":"https://theeasterner.org/#logo","inLanguage":"en-US","url":"https://theeasterner.org/wp-content/uploads/2020/08/Easterner_Header-01.jpg","contentUrl":"https://theeasterner.org/wp-content/uploads/2020/08/Easterner_Header-01.jpg","width":1400,"height":175,"caption":"The Easterner - Eastern Washington University"},"image":{"@id":"https://theeasterner.org/#logo"}},{"@type":"WebSite","@id":"https://theeasterner.org/#website","url":"https://theeasterner.org/","name":"The Easterner","description":"The independent, student-run news site of Eastern Washington University.","publisher":{"@id":"https://theeasterner.org/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://theeasterner.org/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/#primaryimage","inLanguage":"en-US","url":"https://theeasterner.org/wp-content/uploads/2021/04/trevor-bauer-mlb-los-angeles-dodgers-main-image-MLB.png","contentUrl":"https://theeasterner.org/wp-content/uploads/2021/04/trevor-bauer-mlb-los-angeles-dodgers-main-image-MLB.png","width":1000,"height":667,"caption":"The Major League Baseball season is on track for 2021."},{"@type":"WebPage","@id":"https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/#webpage","url":"https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/","name":"Baseball is Back! - The Easterner","isPartOf":{"@id":"https://theeasterner.org/#website"},"primaryImageOfPage":{"@id":"https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/#primaryimage"},"datePublished":"2021-04-19T16:21:05+00:00","dateModified":"2021-04-19T16:21:05+00:00","breadcrumb":{"@id":"https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/"]}]},{"@type":"BreadcrumbList","@id":"https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://theeasterner.org/","url":"https://theeasterner.org/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/","url":"https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/","name":"Baseball is Back!"}}]},{"@type":"Article","@id":"https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/#article","isPartOf":{"@id":"https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/#webpage"},"author":{"@id":"https://theeasterner.org/#/schema/person/55308b20f3b499a46bccb05042ba6fd5"},"headline":"Baseball is Back!","datePublished":"2021-04-19T16:21:05+00:00","dateModified":"2021-04-19T16:21:05+00:00","mainEntityOfPage":{"@id":"https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/#webpage"},"commentCount":0,"publisher":{"@id":"https://theeasterner.org/#organization"},"image":{"@id":"https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/#primaryimage"},"keywords":"baseball,COVID-19,entertainment,Major League Baseball,MLB","articleSection":"Arts &amp; Features,Basketball,Carousel,COVID-19,Men,Positivity,Sports","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/#respond"]}]},{"@type":"Person","@id":"https://theeasterner.org/#/schema/person/55308b20f3b499a46bccb05042ba6fd5","name":"WebEditor","image":{"@type":"ImageObject","@id":"https://theeasterner.org/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/f97cea1ae57a235dfe346b004a27f0e4?s=96&d=retro&r=g","contentUrl":"https://secure.gravatar.com/avatar/f97cea1ae57a235dfe346b004a27f0e4?s=96&d=retro&r=g","caption":"WebEditor"},"sameAs":["https://theeasterner.org"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel="alternate" type="application/rss+xml" title="The Easterner &raquo; Baseball is Back! Comments Feed" href="https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/theeasterner.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
			
	<link rel='stylesheet' id='dashicons-css'  href='https://theeasterner.org/wp-includes/css/dashicons.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://theeasterner.org/wp-includes/js/thickbox/thickbox.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https:////netdna.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.css?ver=4.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://theeasterner.org/wp-content/plugins/menu-icons/vendor/kucrut/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://theeasterner.org/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://theeasterner.org/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://theeasterner.org/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.5' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://theeasterner.org/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://theeasterner.org/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.6' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #d8e1eb;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Brawler%3A400%2C700%7CPT+Sans%3A400%2C700&#038;display=swap&#038;ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://theeasterner.org/wp-content/themes/snoflex/parallax/css/main.css?ver=20191203' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://theeasterner.org/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://theeasterner.org/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://theeasterner.org/wp-content/themes/snoflex/javascript/remodal.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://theeasterner.org/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://theeasterner.org/wp-content/themes/snoflex/style.css?ver=20210247' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-official-css'  href='https://use.fontawesome.com/releases/v5.15.2/css/all.css' type='text/css' media='all' integrity="sha384-vSIIfh2YWi9wW0r9iZe7RJPrKwp6bG+s9QZMoITbCckVJqGCCRhc+ccxNcdpHuYu" crossorigin="anonymous" />
<link rel='stylesheet' id='font-awesome-official-v4shim-css'  href='https://use.fontawesome.com/releases/v5.15.2/css/v4-shims.css' type='text/css' media='all' integrity="sha384-1CjXmylX8++C7CVZORGA9EwcbYDfZV2D4Kl1pTm3hp2I/usHDafIrgBJNuRTDQ4f" crossorigin="anonymous" />
<style id='font-awesome-official-v4shim-inline-css' type='text/css'>
@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.svg#fontawesome") format("svg");
unicode-range: U+F004-F005,U+F007,U+F017,U+F022,U+F024,U+F02E,U+F03E,U+F044,U+F057-F059,U+F06E,U+F070,U+F075,U+F07B-F07C,U+F080,U+F086,U+F089,U+F094,U+F09D,U+F0A0,U+F0A4-F0A7,U+F0C5,U+F0C7-F0C8,U+F0E0,U+F0EB,U+F0F3,U+F0F8,U+F0FE,U+F111,U+F118-F11A,U+F11C,U+F133,U+F144,U+F146,U+F14A,U+F14D-F14E,U+F150-F152,U+F15B-F15C,U+F164-F165,U+F185-F186,U+F191-F192,U+F1AD,U+F1C1-F1C9,U+F1CD,U+F1D8,U+F1E3,U+F1EA,U+F1F6,U+F1F9,U+F20A,U+F247-F249,U+F24D,U+F254-F25B,U+F25D,U+F267,U+F271-F274,U+F279,U+F28B,U+F28D,U+F2B5-F2B6,U+F2B9,U+F2BB,U+F2BD,U+F2C1-F2C2,U+F2D0,U+F2D2,U+F2DC,U+F2ED,U+F328,U+F358-F35B,U+F3A5,U+F3D1,U+F410,U+F4AD;
}
</style>
<link rel='stylesheet' id='wp-paginate-css'  href='https://theeasterner.org/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.1.6' type='text/css' media='screen' />
<script type='text/javascript' src='https://theeasterner.org/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=5.7.1' id='flex-flexslider-script-js'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=5.7.1' id='flex-jquery-visible-js'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=20200802' id='flex-hoverintent-js'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=20200803' id='flex-superfish-js'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=20200803' id='flex-supersubs-js'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=5.7.1' id='flex-scrollfix-js'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/javascript/remodal.min.js?ver=5.7.1' id='flex-remodal-js'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=5.7.1' id='flex-cycle-js'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=5.7.1' id='flex-bnticker-js'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/javascript/menus-init.js?ver=20190826' id='flex-menus-js'></script>
<script type='text/javascript' id='flex-theme-js-js-extra'>
/* <![CDATA[ */
var frontend_ajax_object = {"ajaxurl":"https:\/\/theeasterner.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/javascript/sno-theme.js?ver=20210207' id='flex-theme-js-js'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/parallax/js/skrollr.js?ver=5.7.1' id='flex-parallax-js'></script>
<link rel="https://api.w.org/" href="https://theeasterner.org/wp-json/" /><link rel="alternate" type="application/json" href="https://theeasterner.org/wp-json/wp/v2/posts/49523" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://theeasterner.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://theeasterner.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.1" />
<link rel='shortlink' href='https://theeasterner.org/?p=49523' />
<link rel="alternate" type="application/json+oembed" href="https://theeasterner.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheeasterner.org%2F49523%2Farts-entertainment-features%2Fbaseball-is-back%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://theeasterner.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheeasterner.org%2F49523%2Farts-entertainment-features%2Fbaseball-is-back%2F&#038;format=xml" />


<!-- Start of Open Graph Meta Tags -->

<meta property="og:title" content="Baseball is Back!" />
<meta property="og:type" content="article" />
<meta name="author" content="Michael Spearman" />
<meta property="og:url" content="https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/" />
<meta property="og:image" content="https://theeasterner.org/wp-content/uploads/2021/04/trevor-bauer-mlb-los-angeles-dodgers-main-image-MLB-900x600.png" />
	<meta property="og:image:width" content="900" />
	<meta property="og:image:height" content="600" />
	<meta property="og:site_name" content="The Easterner" />
	<meta property="og:description" content="&nbsp; The MLB season started on time this year, after last season was cut down to only 60 games due to COVID-19 and disagreements between the MLBPA and the MLB owners regarding contract modifications for the season.  The 2020 MLB season finally got underway on Jul. 23 after back-and-forth negotiations that finally ended with the..." />
	<meta name="description" content="&nbsp; The MLB season started on time this year, after last season was cut down to only 60 games due to COVID-19 and disagreements between the MLBPA and the MLB owners regarding contract modifications for the season.  The 2020 MLB season finally got underway on Jul. 23 after back-and-forth negotiations that finally ended with the..." />
	<meta property="article:section" content="Arts &amp; Features" />
	<meta property="article:tag" content="baseball,COVID-19,entertainment,Major League Baseball,MLB" />
<!-- End of Open Graph Meta Tags -->



<script>
	jQuery(document).ready(function() {
		var wpadminbar = jQuery('#wpadminbar').outerHeight();
		if (wpadminbar == null) { var wpadminbar = 0; }
		if (jQuery('#wpadminbar').is(":hidden")) { wpadminbar = 0; }

	
				jQuery('.subnavbarwrap').scrollToFixed({
			marginTop:  wpadminbar,
		});		
		
		
		
	
	});
</script>


<style type="text/css" media="screen">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</style>
</head>

<body data-rsssl=1 class="sno-animate-active"><div class="topnavwrap">
	<div id="topnavbar">
			
			<div class="search-spacer"></div>

			<div class="topnavbarleft classic-icon">
				<style>.topnavbarleft { padding: 0px; width:auto; }</style>    
        								   	    										
    
        				
   	    
    
    		<a target="_blank" href="https://www.youtube.com/user/EasternerFilms">
    		<div class="sno-icon social-border sno-youtube">
        		<i class="fa fa-youtube-play"></i>
        		<span class="icon-hidden-text">YouTube</span>
        	</div>
    	</a>
    
        				
        				    					
        				
						
	    				
    
	
	    
	
	    	<a target="_blank" href="https://www.instagram.com/the_easterner/?hl=en">
    		<div class="sno-icon social-border sno-instagram">
        		<i class="fa fa-instagram"></i>
        		<span class="icon-hidden-text">Instagram</span>
        	</div>
    	</a>
	    				
    		<a target="_blank" href="https://twitter.com/_TheEasterner">
    		<div class="sno-icon social-border sno-twitter">
        		<i class="fa fa-twitter"></i>
        		<span class="icon-hidden-text">Twitter</span>
        	</div>
    	</a>
        				
	    	<a target="_blank" href="https://www.facebook.com/TheEasterner/">
    		<div class="sno-icon social-border sno-facebook">
        		<i class="fa fa-facebook-f"></i>
        		<span class="icon-hidden-text">Facebook</span>
        	</div>
    	</a>
   
   <div class="social-spacer"></div>
   
   			</div>

			<div class="topnavbarcenter">
		        			</div>
	
			<div class="topnavbarright">
					<form method="get" id="searchform7312" action="https://theeasterner.org/">
			<div class="search-button-container" id="searchthis7312">
			<button type="submit" disabled="disabled" id="sno-search-navbar-7312" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s7312" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s7312" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit7312" style="display:none;" value="Search" />
		</form>
				</div>
			
	</div>
	<div class="clear"></div>
</div><div id="sno_mobile_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search-side"><div class="sno-side-menu side-close-icon"><i class="fas fa-times"></i><span class="icon-hidden-text">Close Menu</span></div><form method="get" class="searchform-alt-left" action="https://theeasterner.org/">
									<label for="s-alt-left" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-mobile-menu" class="menu"><li id="menu-item-49073" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49073"><a href="https://theeasterner.org/current-issue/">Current Issue</a></li>
<li id="menu-item-49074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49074"><a href="https://theeasterner.org/category/news/">News</a></li>
<li id="menu-item-49075" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49075"><a href="https://theeasterner.org/category/arts-entertainment-features/">Arts &amp; Features</a></li>
<li id="menu-item-49076" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49076"><a href="https://theeasterner.org/category/sports/">Sports</a></li>
<li id="menu-item-49077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49077"><a href="https://theeasterner.org/category/opinion/">Opinion</a></li>
<li id="menu-item-49078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49078"><a href="https://theeasterner.org/category/multimedia/">Multimedia</a></li>
<li id="menu-item-49079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49079"><a href="https://theeasterner.org/category/2020-elections/">2020 Elections</a></li>
<li id="menu-item-49080" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49080"><a href="https://theeasterner.org/about/">About The Easterner</a></li>
</ul></div></ul></div><div id="wrap" class="bodywrap"><div id="mobile-menu"><div class="sitetitle"><div class="headerlink headersmall" style="display:none"><img src="https://theeasterner.org/wp-content/uploads/2020/09/easterner-logo-web.jpg" class="headerimage" alt="The independent, student-run news site of Eastern Washington University." /></div><div class="headerlink headermedium" style="display:none"><img src="https://theeasterner.org/wp-content/uploads/2020/09/easterner-logo-web.jpg" class="headerimage" alt="The independent, student-run news site of Eastern Washington University." /></div><div class="headerlink headerlarge"><img src="https://theeasterner.org/wp-content/uploads/2020/09/easterner-logo-web.jpg" class="headerlink headerimage" alt="The independent, student-run news site of Eastern Washington University." /></div><h1 style="display:none" aria-hidden="true">The Easterner</h1><script type="text/javascript">
						jQuery(document).ready(function(){
							jQuery(".headerlink").click(function(){
								window.location="https://theeasterner.org";

							});
						});
					</script><div id="hover-menu-side"><div class="sno-menu-side menu-icon"><i class="fas fa-bars"></i><span class="icon-hidden-text">Menu</span></div></div></div><div class="clear"></div></div><div class="leaderboardwrap">
	<div id="leaderboard">
		<div class="leaderboardad snoads_leaderboard">
			<script type="text/javascript">
				jQuery(document).ready(function( $ ) {
					retreive_ad();
					$('.leaderboardad').on('click', '.sno-ad', function() {
						let ad_id = $(this).data('ad-id');
						var url = 'https://snoads.com/api/v1/ad/' + ad_id + '/click';
						jQuery.post(url, '', function(response) {
							console.log(response);
				        });
					});

					$('.leaderboardad').on('click', '.sno-fill-ad', function() {
						url = 'https://snoads.com/site/467';
						window.open(url, '_blank');
					});

			        function retreive_ad() {
			        	var url = 'https://snoads.com/api/v1/adspot/1303/serve'
			        	var ad_fill = "";
						jQuery.get(url, '', function(response) {
							console.log(response);
							if (response) {
								$('.leaderboardad').html('<a target="_blank" href="' + response.link.link + '" class="sno-ad" data-ad-id="' + response.id + '"><img src="' + response.image.url + '" alt="Advertisement" /></a>');
							} else if (ad_fill) {
								$('.leaderboardad').html('<img class="sno-fill-ad" src="' + ad_fill + '" alt="Advertisement" />');
							} else {
								let rand_num = Math.floor((Math.random() * 3) + 1);
								$('.leaderboardad').html('<img class="sno-fill-ad" src="https://snoads.s3.amazonaws.com/sno_ad_fill/728x90_' + rand_num + '.jpg" alt="Advertisement"/>');
							}
				        });
			        }
				});
			</script>
		</div>
	</div>
</div><div class="headerwrap"><div id="header" style="position:relative;"><div class="headerlarge"><a href="https://theeasterner.org"><img src="https://theeasterner.org/wp-content/uploads/2020/09/easterner-logo-web.jpg" class="headerimage" alt="The independent, student-run news site of Eastern Washington University." /></a></div><h1 style="display:none">The Easterner</h1></div></div><div class="bottom-menu"><div class='subnavbarwrap sno-sticky'
						data-align='left' 
						data-margin='0' 
						data-style='Bar' 
						data-minilogo='false' 
						data-mode='default' 
						data-height='30px' 
						data-width='1390'><div class="subnavbarcontainer"><div id="subnavbar"><div id="subnavbarbackground"><ul id='show-mini-logo-bottom'  style="display:none" ><a href="/"><li id="mini-logo-bottom" style="float:left;"><img src="https://theeasterner.org/wp-content/uploads/2019/02/Screen-Shot-2019-02-11-at-9.07.46-AM.png" alt="The independent, student-run news site of Eastern Washington University." />
								</li></a>
							</ul><div id="menu-b-menu"><nav aria-label="Main Menu"><div class="menu-main-menu-container"><ul id="menu-main-menu" class="sf-menu sno-bottom-menu"><li id="menu-item-48972" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48972"><a href="https://theeasterner.org/current-issue/">Current Issue</a></li>
<li id="menu-item-48973" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-48973" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://theeasterner.org/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-49007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49007"><a href="https://theeasterner.org/category/covid-19/economy/">Economy</a></li>
	<li id="menu-item-49013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49013"><a href="https://theeasterner.org/category/news/politics/">Politics</a></li>
	<li id="menu-item-49017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49017"><a href="https://theeasterner.org/category/police-beat/">Police Beat</a></li>
	<li id="menu-item-49020" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49020"><a href="https://theeasterner.org/category/covid-19/">COVID-19</a></li>
</ul>
</li>
<li id="menu-item-48974" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-48974" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://theeasterner.org/category/arts-entertainment-features/">Arts &amp; Features</a>
<ul class="sub-menu">
	<li id="menu-item-49022" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49022"><a href="https://theeasterner.org/category/eagle-life/">Eagle Life</a></li>
</ul>
</li>
<li id="menu-item-48975" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-48975" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://theeasterner.org/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-49021" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49021"><a href="https://theeasterner.org/category/sports/football/">Football</a></li>
	<li id="menu-item-49009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49009"><a href="https://theeasterner.org/category/sports/volleyball/">Volleyball</a></li>
	<li id="menu-item-49018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49018"><a href="https://theeasterner.org/category/sports/soccer/">Soccer</a></li>
	<li id="menu-item-49012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49012"><a href="https://theeasterner.org/category/sports/hockey/">Hockey</a></li>
	<li id="menu-item-49006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49006"><a href="https://theeasterner.org/category/sports/tennis/">Tennis</a></li>
	<li id="menu-item-49008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49008"><a href="https://theeasterner.org/category/sports/track-and-field/">Track and field</a></li>
	<li id="menu-item-49010" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49010"><a href="https://theeasterner.org/category/sports/club-sports/">Club sports</a></li>
</ul>
</li>
<li id="menu-item-48976" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-48976" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://theeasterner.org/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-49011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49011"><a href="https://theeasterner.org/category/column/">Column</a></li>
	<li id="menu-item-49015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49015"><a href="https://theeasterner.org/category/opinion/easterner-asks/">Easterner asks</a></li>
</ul>
</li>
<li id="menu-item-48977" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-48977" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://theeasterner.org/category/multimedia/">Multimedia</a>
<ul class="sub-menu">
	<li id="menu-item-49019" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49019"><a href="https://theeasterner.org/category/editorial/">Editorial</a></li>
	<li id="menu-item-49016" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49016"><a href="https://theeasterner.org/category/multimedia/video/">Video</a></li>
	<li id="menu-item-49014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49014"><a href="https://theeasterner.org/category/multimedia/looking-back/">Looking Back</a></li>
</ul>
</li>
<li id="menu-item-49002" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-49002" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://theeasterner.org/category/2020-elections/">2020 Elections</a>
<ul class="sub-menu">
	<li id="menu-item-49003" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49003"><a href="https://theeasterner.org/category/2020-elections/asewu-2020-elections/">ASEWU</a></li>
	<li id="menu-item-49004" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49004"><a href="https://theeasterner.org/category/2020-elections/local/">Local</a></li>
	<li id="menu-item-49005" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49005"><a href="https://theeasterner.org/category/2020-elections/federal/">Federal</a></li>
</ul>
</li>
<li id="menu-item-48978" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-48978" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://theeasterner.org/about/">About The Easterner</a>
<ul class="sub-menu">
	<li id="menu-item-49061" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49061"><a href="https://theeasterner.org/about/staff/">Staff</a></li>
	<li id="menu-item-48979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48979"><a href="https://theeasterner.org/advertising/">Advertising</a></li>
</ul>
</li>
</ul></div></nav><div class="clear"></div></div><ul id='menu-more-bottom' class='sf-menu sf-js-enabled sf-shadow' style='display:none'><li id="menu-more-item-bottom" style="float:left;"><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"> »</span></a>
							<ul id="add-more-bottom" class="sub-menu"></ul>
							</li>
						</ul></div><div class="clear"></div></div></div></div></div><div class="clear"></div>				<script type="text/javascript">
					jQuery(document).ready(function() {
						jQuery(".newsticker3-jcarousellite").jCarouselLite({
        					vertical: true,
        					visible: 1,
        					auto:0,
        					speed:2000    					});
					});
				</script><div id="fullwrap" style="position:relative;"><div id="outerbackgroundwrap"><div class="innerbackgroundwrap "><div class="innerbackground"><div id='snopostid-49523' class='snopostid'><div id='classic_story' class='sno-story-49523'><div id="content"><div id='contentleft'><div class="postarea"><ul class="snocategories"><li class='blockscategory'><a href='https://theeasterner.org/category/arts-entertainment-features/' rel='category tag'>Arts &amp; Features</a></li><li class='blockscategory'><a href='https://theeasterner.org/category/sports/basketball/' rel='category tag'>Basketball</a></li><li class='blockscategory'><a href='https://theeasterner.org/category/carousel/' rel='category tag'>Carousel</a></li><li class='blockscategory'><a href='https://theeasterner.org/category/covid-19/' rel='category tag'>COVID-19</a></li><li class='blockscategory'><a href='https://theeasterner.org/category/sports/basketball/men/' rel='category tag'>Men</a></li><li class='blockscategory'><a href='https://theeasterner.org/category/covid-19/positivity/' rel='category tag'>Positivity</a></li><li class='blockscategory'><a href='https://theeasterner.org/category/sports/' rel='category tag'>Sports</a></li></ul><div role="main"><h1 class="storyheadline">Baseball is Back!</h1><div class="storyshadow"><div class="photowrap"><a class='modal-photo photooverlay' data-story-id='49523' data-photo-id='49525' href='#photo'><img src='https://theeasterner.org/wp-content/uploads/2021/04/trevor-bauer-mlb-los-angeles-dodgers-main-image-MLB-900x600.png' alt='The+Major+League+Baseball+season+is+on+track+for+2021.' style='width:100%' class='catboxphoto feature-image' /></a><div class='modal-photo photo-enlarge' data-story-id='49523' data-photo-id='49525'><i class='fas fa-search-plus'></i></div></div><div class="clear"></div><div class="captionboxmittop"><p class="photocaption">The Major League Baseball season is on track for 2021.</p></div></div><div class="clear"></div><div class="permalinkphotobox"></div><div class="storydetails"><p><span class="storybyline">By <a href="https://theeasterner.org/staff_name/michael-spearman/" class="creditline">Michael Spearman</a>, Reporter</span><br /><span class="storydate"><span class="time-wrapper">April 19, 2021</span></span></p></div><div class="sharing sharing-top" data-story-id="49523"><a class='commentscroll' href='https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/#respond ' title='Jump to Comments'><div class='sharing-icon sno-comments  sharing-mobile-hide'><i class='fa fa-comments-o'></i><span class='icon-hidden-text'>Jump to Comments</span></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ftheeasterner.org%2F49523%2Farts-entertainment-features%2Fbaseball-is-back%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook sharing-mobile-hide"><i class="fa fa-facebook-f"></i><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Baseball is Back!&amp;url=https%3A%2F%2Ftheeasterner.org%2F%3Fp%3D49523" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter sharing-mobile-hide"><i class="fa fa-twitter"></i><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email sharing-mobile-hide"><i class="fa fa-envelope"></i><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//theeasterner.org/49523/arts-entertainment-features/baseball-is-back/?print=true"><div class="sharing-icon sno-print sharing-mobile-hide"><i class="fa fa-print"></i><span class="icon-hidden-text">Print</span></div></a></div><div class="sharing-clear"></div><span class="storycontent"><p>&nbsp;</p>
<p><span style="font-weight: 400;">The MLB season started on time this year, after last season was cut down to only 60 games due to COVID-19 and disagreements between the MLBPA and the MLB owners regarding contract modifications for the season. </span></p>
<p><span style="font-weight: 400;">The 2020 MLB season finally got underway on Jul. 23 after back-and-forth negotiations that finally ended with the two sides agreeing on a 60-game season with a universal designated hitter, among other specific details. The season went relatively smoothly besides a few hiccups, and ended on Oct. 27 with the Los Angeles Dodgers lifting the World Series trophy as they beat the Tampa Bay Rays 4-2. </span></p>
<p><span style="font-weight: 400;">Fast forward to today, the MLB season is back to normal. The MLB was able to have a normal offseason with an uninterrupted spring training season. The offseason gave fans some exciting new faces in new places, with the biggest signing of the offseason being former starting pitcher for the Cincinnati Reds and Cy Young winner Trevor Bauer, who signed a three-year $102 million dollar contract with the Dodgers. Other signings from over the offseason consisted of outfielder Marcell Ozuna resigning with the Atlanta Braves for $64 million dollars over four-years with a club option in 2025; shortstop Didi Gregorius resigned with the Phillies inking a two-year deal worth $28 million dollars; catcher J.T. Realmuto cashed in big by resigning with the Phillies as well and secured a five-year $115.5 million dollar deal; former Astros’ outfielder George Springer found a new home with the Blue Jays and was another player who got a three figure deal worth $150 million dollars over six-years; the last big name on the list was the utility infielder himself DJ LeMahieu who reupped with the Yankees after signing a contract worth $90 million dollars over the next six-years. </span></p>
<figure id="attachment_49524" aria-describedby="caption-attachment-49524" style="width: 345px" class="wp-caption aligncenter"><img loading="lazy" class="size-medium wp-image-49524" src="https://theeasterner.org/wp-content/uploads/2021/04/los-angeles-dodgers-MLB-345x475.jpg" alt="" width="345" height="475" srcset="https://theeasterner.org/wp-content/uploads/2021/04/los-angeles-dodgers-MLB-345x475.jpg 345w, https://theeasterner.org/wp-content/uploads/2021/04/los-angeles-dodgers-MLB-300x414.jpg 300w, https://theeasterner.org/wp-content/uploads/2021/04/los-angeles-dodgers-MLB.jpg 370w" sizes="(max-width: 345px) 100vw, 345px" /><figcaption id="caption-attachment-49524" class="wp-caption-text">LOS ANGELES, CALIFORNIA &#8211; MARCH 30: The Los Angeles Dodgers celebrate their 6-4 win over the Los Angeles Angels on March 30, 2021 in Los Angeles, California. (Photo by Meg Oliphant/Getty Images) (Getty Images)</figcaption></figure>
<p><span style="font-weight: 400;">Fans not only saw big name talents sign with other teams but actually were traded too. We saw teams trade away their top players in blockbuster deals, like the Rockies did when they traded third baseman Nolan Arenado to the Cardinals in exchange for left-handed pitcher Austin Gomber and four prospects; the Padres traded for Joe Musgrove from the Pirates and gave up right-handed pitcher David Bednar along with 4 prospects; the Padres also went out and got the Cubs starting right-handed pitcher Yu Darvish and gave up right-handed pitcher Zach Davies and four other prospects; the Indians parted ways with their All-Star shortstop Francisco Lindor by shipping him off to the Mets and in return received infielders Amed Rosario, Andrés Giménez, and two top 10 Mets minor league prospects in right-handed pitcher Josh Wolf and outfielder Isaiah Greene; last but not least we saw probably the most shocking trade of the offseason happen when the Rays traded away their star left-handed pitcher Blake Snell to once again, you guessed it, the Padres, in return the Rays acquired pitchers Luis Patiño and Cole Wilcox and catchers Blake Hunt and Francisco Mejía. </span></p>
<p><span style="font-weight: 400;">Spring training went well as we were able to see top talent with their new teams and young prospects that have a chance to make it to the big league this year. Once spring training was all said and done, the top team in the Grapefruit league was the Marlins sitting at (14-5) with the Blue Jays (16-9) and Red Sox (16-11) right behind them. In the Cactus league, the Royals (16-8) led the league as the Cubs (15-9) and A’s (16-10) were 2</span><span style="font-weight: 400;">nd</span><span style="font-weight: 400;"> and 3</span><span style="font-weight: 400;">rd</span><span style="font-weight: 400;"> respectively. </span></p>
<p><span style="font-weight: 400;">After two and half weeks into the regular season, there are a few big topics within the league. ESPN releases their first updated MLB power rankings of the year which had the Dodgers number one overall, and the Pirates dead last at 30</span><span style="font-weight: 400;">th</span><span style="font-weight: 400;"> overall. Some of the teams that shot up the rankings include, the Reds who were previously ranked 19</span><span style="font-weight: 400;">th</span><span style="font-weight: 400;"> jumped up 6 spots and are now sitting at number 13; the White Sox were another team that improved from their previous 12 spot to now being ranked inside the top 10 at number 7; the team that jumped up the board the most though was the Red Sox who sat near the bottom of the pack at 21 and are now ranked 12</span><span style="font-weight: 400;">th</span><span style="font-weight: 400;">. When there are teams that increase their ranking, there are teams bound to fall down the board too such as, the Nationals who started the season right in the middle of the league at 15 but fell 6 spots to finally land at 21; the Cubs were another team that fell drastically, they were right in front of the Nationals before the season ranked 14</span><span style="font-weight: 400;">th</span><span style="font-weight: 400;"> and now sit in front of them again but this time at number 20. </span></p>
<p><span style="font-weight: 400;">There’s no need to get heated if your team hasn’t looked or played the best. Just remember it’s a long, and I mean long, season with 162 games, so buckle that seat belt. The same goes for those that are loving the beginning of the season, there have been plenty of times where teams start off hot only to finish third or fourth in their division.  </span></p>
<p>&nbsp;</p>
</span><div class="clear"></div></div><ul class="snotags"><li class="blockstag"><a href="https://theeasterner.org/tag/baseball/" rel="tag">baseball</a></li><li class="blockstag"><a href="https://theeasterner.org/tag/covid-19/" rel="tag">COVID-19</a></li><li class="blockstag"><a href="https://theeasterner.org/tag/entertainment/" rel="tag">entertainment</a></li><li class="blockstag"><a href="https://theeasterner.org/tag/major-league-baseball/" rel="tag">Major League Baseball</a></li><li class="blockstag"><a href="https://theeasterner.org/tag/mlb/" rel="tag">MLB</a></li></ul><div class="aboutwriter"><div class='aboutwritertitle'>About the Contributor</div>
<!-- profile displayed from cache -->
<div class='storycreditboxwide'><a href="https://theeasterner.org/staff_profile/michael-spearman/"><div class='sc_title'>Michael Spearman, </div></a><div class='sc_bio' style='width:100%;'><p></p><div class='clear'></div></div></div><div class="clear"></div></div></div><div class="clear"></div><div id="commentswrap"><div class="widgetwrap"><div class="titlewrap cursorpoint" id="commentsbox"><div tabindex="0" role="button" aria-expanded="true" class="commenttoggle fa fa-minus-square"></div><div class="widgettitle-nonsno">Leave a Comment</div></div><div id='commentsbody' class='widgetbody' style='display:block;'>


<!-- You can start editing here. -->



<div id="commentblock">




	
		<!-- If comments are open, but there are no comments. -->



	 








<p id="respond">
The Easterner reserves the right to edit or delete hate speech, inflammatory statements or vulgarities in comments. The Easterner also reserves the right to delete advertising from comments.<br /><br />
If you want a picture to show with your comment, go get a <a href="https://en.gravatar.com">gravatar</a>.</p>





<form action="https://theeasterner.org/wp-comments-post.php" method="post" id="commentform">






<p><label for="name">Name (required)</label><br />

<input type="text" name="author" id="name" value="" size="50" tabindex="1" /></p>



<p><label for="email">Email Address (required)</label><br />

<input type="text" name="email" id="email" value="" size="50" tabindex="2" /></p>








<!--<p><small><strong>XHTML:</strong> You can use these tags: </small></p>-->


<div style="display:none"><label for="spam_stopper">Spam Control Field. Please Ignore</label><input type="text" name="sno_is_legit_comment" id="spam_stopper" value="SNO_Spam_Stopper"/></p></div>

	             		<script type="text/javascript">
							jQuery(function(){
								jQuery('input[name="sno_is_legit_comment"]').attr('name', 'sno_stop_spam');
							});
						</script>


<p><label for="words">Speak your mind</label><br /><textarea name="comment" id="words" cols="40" rows="10" tabindex="4"></textarea></p>



<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />

<input type="hidden" name="comment_post_ID" value="49523" /></p>






</form>









</div></div><div class="widgetfooter"></div></div></div></div><div id="sidebar" class="sidebar-template">		

			<section>
				<style>
														</style>
				<div class='widgetwrap sno-animate sno-page-6 widget-shadow'>
					
																	<div class="catboxthumbnail" style="float: Left; width: 100%; height: ; margin-left: 0px; margin-bottom: 0px;">
							<a href="https://theeasterner.org/pollsarchive/">
								<img src="https://theeasterner.org/wp-content/uploads/2020/05/online-900x900.jpg" style="width:100%" alt="Image obtained from Flickr" />
							</a>
						</div>						
										
											<div style="position: relative; height: ;">
							<div class=" sno-center-v" style="float: right; width: calc(100% - 130px); padding-left: 60px; padding-right: 60px; font-size: 18px; line-height: 27px; text-align: center;">
								    <br />
<br />
<hr /><br />
<br />
							</div>
						</div>
						
					
		  				<div class="widget-expander" style="padding-bottom:0px"></div>
		  				<div class="clear"></div>
				
								
		
				</div>
			</section>

                         
	<div style="clear:both"></div><section><div class="widgetwrap sno-animate"><div></div><div class="titlewrap" role="heading"><div class="widgettitle-nonsno">Search Easterner Online</div></div><div class="widgetbody">	<form method="get" id="searchform7165" action="https://theeasterner.org/">
			<div class="search-button-container" id="searchthis7165">
			<button type="submit" disabled="disabled" id="sno-search-navbar-7165" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s7165" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s7165" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit7165" style="display:none;" value="Search" />
		</form>
	</div><div class="widgetfooter3"></div></div></section>
<!-- widget displayed from cache -->
<section><style>.sno-category-36 .widgetbody { padding: 15px; }</style><div class='widgetwrap sno-story-list-widget sno-category-36  widget-shadow  sno-animate' style=''><div style="overflow: hidden;border-bottom: 3px solid #aaaaaa;border-top: 1px solid #aaaaaa;background: #ffffff;margin-bottom:0px;"><div class="widget7 widgettitle" role="heading"style="background: #ffffff!important;margin-top:1px;margin-bottom:1px;background-color: #ffffff !important;color: #000000 !important;font-size:17px;line-height: 26px;text-align:left;padding: 6px 0px 2px 10px;"><a style='color: #000000 !important;' href='/'>Recent Stories</a></div></div><div class="clear"></div><div class="widgetbody7 widgetbody" style="background-color: #ffffff !important;border:none!important;padding:10px;margin:0px 0px 0px !important;"><div class="story-widget-secondary " style=" width: 100%; margin-top: 15px; margin-top: 0;"><div class="dual-format-card-wrap" style=""><div class="dual-format-card" style=" background: #ffffff; color: #000000; margin-bottom: 15px;"><div class="dual-format-photo-spacer dual-format-photo-wrap" style=" width: 90px; height: 90px; float: left; margin-right: 15px;"><img class='enlarge-effect' style='width:100%; height: 100%; object-fit: cover;' src='https://theeasterner.org/wp-content/uploads/2021/04/trevor-bauer-mlb-los-angeles-dodgers-main-image-MLB-900x600.png' alt='The Major League Baseball season is on track for 2021.' /></div><div class='sno-story-card-text-wrap ' style=' float: left; margin-bottom: 7.5px; height: 90px; overflow: hidden; height: unset; float: left; width: calc(100% - 90px - 30px);'><div class='sno-story-card-text-area  ' style=''><div class='sno-story-card-link' style=' font-size: 16px; line-height: 20.8px;'><a href='https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/' class='homeheadline'>Baseball is Back!</a></div><div class='sno-story-card-meta' style=' font-size: 12px; line-height: 18px; margin-top: 7.5px;'><span class="time-wrapper"> April 19, 2021</span></div></div></div><div class="clear"></div></div></div><div class="dual-format-card-wrap" style=""><div class="dual-format-card" style=" background: #ffffff; color: #000000; margin-bottom: 15px;"><div class="dual-format-photo-spacer dual-format-photo-wrap" style=" width: 90px; height: 90px; float: left; margin-right: 15px;"><img class='enlarge-effect' style='width:100%; height: 100%; object-fit: cover;' src='https://theeasterner.org/wp-content/uploads/2020/09/staff-button-900x257.jpg' alt='Grant Wengeler joins The Easterner' /></div><div class='sno-story-card-text-wrap ' style=' float: left; margin-bottom: 7.5px; height: 90px; overflow: hidden; height: unset; float: left; width: calc(100% - 90px - 30px);'><div class='sno-story-card-text-area  ' style=''><div class='sno-story-card-link' style=' font-size: 16px; line-height: 20.8px;'><a href='https://theeasterner.org/49520/carousel/grant-wengeler-joins-the-easterner/' class='homeheadline'>Grant Wengeler joins The Easterner</a></div><div class='sno-story-card-meta' style=' font-size: 12px; line-height: 18px; margin-top: 7.5px;'><span class="time-wrapper"> April 17, 2021</span></div></div></div><div class="clear"></div></div></div><div class="dual-format-card-wrap" style=""><div class="dual-format-card" style=" background: #ffffff; color: #000000; margin-bottom: 15px;"><div class="dual-format-photo-spacer dual-format-photo-wrap" style=" width: 90px; height: 90px; float: left; margin-right: 15px;"><img class='enlarge-effect' style='width:100%; height: 100%; object-fit: cover;' src='https://theeasterner.org/wp-content/uploads/2010/04/graduation.jpg' alt='Virtual Commencement' /></div><div class='sno-story-card-text-wrap ' style=' float: left; margin-bottom: 7.5px; height: 90px; overflow: hidden; height: unset; float: left; width: calc(100% - 90px - 30px);'><div class='sno-story-card-text-area  ' style=''><div class='sno-story-card-link' style=' font-size: 16px; line-height: 20.8px;'><a href='https://theeasterner.org/49517/carousel/virtual-commencement/' class='homeheadline'>Virtual Commencement</a></div><div class='sno-story-card-meta' style=' font-size: 12px; line-height: 18px; margin-top: 7.5px;'><span class="time-wrapper"> April 15, 2021</span></div></div></div><div class="clear"></div></div></div><div class="dual-format-card-wrap" style=""><div class="dual-format-card" style=" background: #ffffff; color: #000000; margin-bottom: 15px;"><div class="dual-format-photo-spacer dual-format-photo-wrap" style=" width: 90px; height: 90px; float: left; margin-right: 15px;"><img class='enlarge-effect' style='width:100%; height: 100%; object-fit: cover;' src='https://theeasterner.org/wp-content/uploads/2013/04/caseawards2013_247.jpg' alt='Student awards' /></div><div class='sno-story-card-text-wrap ' style=' float: left; margin-bottom: 7.5px; height: 90px; overflow: hidden; height: unset; float: left; width: calc(100% - 90px - 30px);'><div class='sno-story-card-text-area  ' style=''><div class='sno-story-card-link' style=' font-size: 16px; line-height: 20.8px;'><a href='https://theeasterner.org/49514/community/student-awards/' class='homeheadline'>Student awards</a></div><div class='sno-story-card-meta' style=' font-size: 12px; line-height: 18px; margin-top: 7.5px;'><span class="time-wrapper"> April 15, 2021</span></div></div></div><div class="clear"></div></div></div></div><div class="widget-expander" style="padding-bottom:0px"></div><div class="clear"></div></div><div style='display:inline-block;'></div></div></section><div style="clear:both"></div><section><div class="widgetwrap sno-animate"><div></div><div class="titlewrap" role="heading"><div class="widgettitle-nonsno">Archive: 2012-Current</div></div><div class="widgetbody">		<label class="screen-reader-text" for="archives-dropdown-5">Archive: 2012-Current</label>
		<select id="archives-dropdown-5" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://theeasterner.org/date/2021/04/'> April 2021 </option>
	<option value='https://theeasterner.org/date/2021/03/'> March 2021 </option>
	<option value='https://theeasterner.org/date/2021/02/'> February 2021 </option>
	<option value='https://theeasterner.org/date/2021/01/'> January 2021 </option>
	<option value='https://theeasterner.org/date/2020/12/'> December 2020 </option>
	<option value='https://theeasterner.org/date/2020/11/'> November 2020 </option>
	<option value='https://theeasterner.org/date/2020/10/'> October 2020 </option>
	<option value='https://theeasterner.org/date/2020/09/'> September 2020 </option>
	<option value='https://theeasterner.org/date/2020/08/'> August 2020 </option>
	<option value='https://theeasterner.org/date/2020/06/'> June 2020 </option>
	<option value='https://theeasterner.org/date/2020/05/'> May 2020 </option>
	<option value='https://theeasterner.org/date/2020/04/'> April 2020 </option>
	<option value='https://theeasterner.org/date/2020/03/'> March 2020 </option>
	<option value='https://theeasterner.org/date/2020/02/'> February 2020 </option>
	<option value='https://theeasterner.org/date/2020/01/'> January 2020 </option>
	<option value='https://theeasterner.org/date/2019/12/'> December 2019 </option>
	<option value='https://theeasterner.org/date/2019/11/'> November 2019 </option>
	<option value='https://theeasterner.org/date/2019/10/'> October 2019 </option>
	<option value='https://theeasterner.org/date/2019/09/'> September 2019 </option>
	<option value='https://theeasterner.org/date/2019/08/'> August 2019 </option>
	<option value='https://theeasterner.org/date/2019/07/'> July 2019 </option>
	<option value='https://theeasterner.org/date/2019/06/'> June 2019 </option>
	<option value='https://theeasterner.org/date/2019/05/'> May 2019 </option>
	<option value='https://theeasterner.org/date/2019/04/'> April 2019 </option>
	<option value='https://theeasterner.org/date/2019/03/'> March 2019 </option>
	<option value='https://theeasterner.org/date/2019/02/'> February 2019 </option>
	<option value='https://theeasterner.org/date/2019/01/'> January 2019 </option>
	<option value='https://theeasterner.org/date/2018/12/'> December 2018 </option>
	<option value='https://theeasterner.org/date/2018/11/'> November 2018 </option>
	<option value='https://theeasterner.org/date/2018/10/'> October 2018 </option>
	<option value='https://theeasterner.org/date/2018/09/'> September 2018 </option>
	<option value='https://theeasterner.org/date/2018/08/'> August 2018 </option>
	<option value='https://theeasterner.org/date/2018/07/'> July 2018 </option>
	<option value='https://theeasterner.org/date/2018/06/'> June 2018 </option>
	<option value='https://theeasterner.org/date/2018/05/'> May 2018 </option>
	<option value='https://theeasterner.org/date/2018/04/'> April 2018 </option>
	<option value='https://theeasterner.org/date/2018/03/'> March 2018 </option>
	<option value='https://theeasterner.org/date/2018/02/'> February 2018 </option>
	<option value='https://theeasterner.org/date/2018/01/'> January 2018 </option>
	<option value='https://theeasterner.org/date/2017/12/'> December 2017 </option>
	<option value='https://theeasterner.org/date/2017/11/'> November 2017 </option>
	<option value='https://theeasterner.org/date/2017/10/'> October 2017 </option>
	<option value='https://theeasterner.org/date/2017/09/'> September 2017 </option>
	<option value='https://theeasterner.org/date/2017/08/'> August 2017 </option>
	<option value='https://theeasterner.org/date/2017/07/'> July 2017 </option>
	<option value='https://theeasterner.org/date/2017/06/'> June 2017 </option>
	<option value='https://theeasterner.org/date/2017/05/'> May 2017 </option>
	<option value='https://theeasterner.org/date/2017/04/'> April 2017 </option>
	<option value='https://theeasterner.org/date/2017/03/'> March 2017 </option>
	<option value='https://theeasterner.org/date/2017/02/'> February 2017 </option>
	<option value='https://theeasterner.org/date/2017/01/'> January 2017 </option>
	<option value='https://theeasterner.org/date/2016/12/'> December 2016 </option>
	<option value='https://theeasterner.org/date/2016/11/'> November 2016 </option>
	<option value='https://theeasterner.org/date/2016/10/'> October 2016 </option>
	<option value='https://theeasterner.org/date/2016/09/'> September 2016 </option>
	<option value='https://theeasterner.org/date/2016/08/'> August 2016 </option>
	<option value='https://theeasterner.org/date/2016/06/'> June 2016 </option>
	<option value='https://theeasterner.org/date/2016/04/'> April 2016 </option>
	<option value='https://theeasterner.org/date/2016/03/'> March 2016 </option>
	<option value='https://theeasterner.org/date/2016/02/'> February 2016 </option>
	<option value='https://theeasterner.org/date/2016/01/'> January 2016 </option>
	<option value='https://theeasterner.org/date/2015/12/'> December 2015 </option>
	<option value='https://theeasterner.org/date/2015/11/'> November 2015 </option>
	<option value='https://theeasterner.org/date/2015/10/'> October 2015 </option>
	<option value='https://theeasterner.org/date/2015/09/'> September 2015 </option>
	<option value='https://theeasterner.org/date/2015/06/'> June 2015 </option>
	<option value='https://theeasterner.org/date/2015/05/'> May 2015 </option>
	<option value='https://theeasterner.org/date/2015/04/'> April 2015 </option>
	<option value='https://theeasterner.org/date/2015/03/'> March 2015 </option>
	<option value='https://theeasterner.org/date/2015/02/'> February 2015 </option>
	<option value='https://theeasterner.org/date/2015/01/'> January 2015 </option>
	<option value='https://theeasterner.org/date/2014/12/'> December 2014 </option>
	<option value='https://theeasterner.org/date/2014/11/'> November 2014 </option>
	<option value='https://theeasterner.org/date/2014/10/'> October 2014 </option>
	<option value='https://theeasterner.org/date/2014/09/'> September 2014 </option>
	<option value='https://theeasterner.org/date/2014/08/'> August 2014 </option>
	<option value='https://theeasterner.org/date/2014/07/'> July 2014 </option>
	<option value='https://theeasterner.org/date/2014/06/'> June 2014 </option>
	<option value='https://theeasterner.org/date/2014/05/'> May 2014 </option>
	<option value='https://theeasterner.org/date/2014/04/'> April 2014 </option>
	<option value='https://theeasterner.org/date/2014/03/'> March 2014 </option>
	<option value='https://theeasterner.org/date/2014/02/'> February 2014 </option>
	<option value='https://theeasterner.org/date/2014/01/'> January 2014 </option>
	<option value='https://theeasterner.org/date/2013/12/'> December 2013 </option>
	<option value='https://theeasterner.org/date/2013/11/'> November 2013 </option>
	<option value='https://theeasterner.org/date/2013/10/'> October 2013 </option>
	<option value='https://theeasterner.org/date/2013/09/'> September 2013 </option>
	<option value='https://theeasterner.org/date/2013/08/'> August 2013 </option>
	<option value='https://theeasterner.org/date/2013/06/'> June 2013 </option>
	<option value='https://theeasterner.org/date/2013/05/'> May 2013 </option>
	<option value='https://theeasterner.org/date/2013/04/'> April 2013 </option>
	<option value='https://theeasterner.org/date/2013/03/'> March 2013 </option>
	<option value='https://theeasterner.org/date/2013/02/'> February 2013 </option>
	<option value='https://theeasterner.org/date/2013/01/'> January 2013 </option>
	<option value='https://theeasterner.org/date/2012/12/'> December 2012 </option>
	<option value='https://theeasterner.org/date/2012/11/'> November 2012 </option>
	<option value='https://theeasterner.org/date/2012/10/'> October 2012 </option>
	<option value='https://theeasterner.org/date/2012/09/'> September 2012 </option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-5" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</div><div class="widgetfooter3"></div></div></section><!-- Size: 11 -->
<div class='snoadnetwork'>
	<div class='sidebar-ad'>
		<script type="text/javascript">
			jQuery(document).ready(function( $ ) {
				retreive_ad();
				$('.sidebar-ad').on('click', '.sno-ad', function() {
					let ad_id = $(this).data('ad-id');
					url = 'https://snoads.com/api/v1/ad/' + ad_id + '/click';
					jQuery.post(url, '', function(response) {
						console.log(response);
			        });
				});
				$('.sidebar-ad').on('click', '.sno-fill-ad', function() {
					url = 'https://snoads.com/site/467';
					window.open(url, '_blank');
				});
		        function retreive_ad() {
		        	var url = 'https://snoads.com/api/v1/adspot/622/serve'
		        	var fill_ad = "";
					jQuery.get(url, '', function(response) {
						if (response) {
							$('.sidebar-ad').html('<a target="_blank" href="' + response.link.link + '" class="sno-ad" data-ad-id="' + response.id + '"><img src="' + response.image.url + '" alt="Advertisement" /></a>');
						} else if (fill_ad) {
							$('.sidebar-ad').html('<img class="sno-fill-ad" src="' + fill_ad + '" alt="Advertisement" />');
						} else {
							let rand_num = Math.floor((Math.random() * 3) + 1);
							$('.sidebar-ad').html('<img class="sno-fill-ad" src="https://snoads.s3.amazonaws.com/sno_ad_fill/300x250_' + rand_num + '.jpg" alt="Advertisement" />');
						}
			        });
		        }
			});
		</script>
	</div>
</div><div class="clear"></div></div></div></div></div><div class="sno_teaserbar" id="sno_teaserbar"><div class="stb_nav"><div class="custom-navigation"><span class="flex-prev"><div class="stb_left"><div class="fa fa-angle-left"><div class="icon-hidden-text">Navigate Left</div></div></div></span></div></div><div id='stb-container' class='flexslider'><ul class="slides"><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/49504/carousel/breaking-down-breaking-news-8/#photo'><img src='https://theeasterner.org/wp-content/uploads/2021/04/prince-philip-475x264.jpg' id='grow-stb49504'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Prince Philip, Duke of Edinburgh and husband of Queen Elizabeth II, passed away on April 9 at age 99. '/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb49504').mouseenter(function() {
   											jQuery('#grow-stb49504').removeClass('shrink');
   											jQuery('#grow-stb49504').removeClass('grow');
   											jQuery('#grow-stb49504').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb49504').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Features</p><p class="relatedtitle"><a href="https://theeasterner.org/49504/carousel/breaking-down-breaking-news-8/">Breaking Down Breaking News</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/49491/carousel/hamilton-the-award-winning-musical/#photo'><img src='https://theeasterner.org/wp-content/uploads/2021/04/hamilton-disney-plus-475x316.jpg' id='grow-stb49491'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='NEW YORK, NY - JUNE 12:  Lin-Manuel Miranda and the cast of 'Hamilton' perform onstage during the 70th Annual Tony Awards at The Beacon Theatre on June 12, 2016 in New York City.  (Photo by Theo Wargo/Getty Images for Tony Awards Productions)'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb49491').mouseenter(function() {
   											jQuery('#grow-stb49491').removeClass('shrink');
   											jQuery('#grow-stb49491').removeClass('grow');
   											jQuery('#grow-stb49491').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb49491').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Features</p><p class="relatedtitle"><a href="https://theeasterner.org/49491/carousel/hamilton-the-award-winning-musical/">Hamilton: The award-winning musical</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/49461/arts-entertainment-features/139-years-of-education-with-eastern/#photo'><img src='https://theeasterner.org/wp-content/uploads/2014/09/15137352168_94b8051bc7_z-475x316.jpg' id='grow-stb49461'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Swoop, EWU mascot, leads new students toward Showalter Hall at the Passing Through The Pillars event on Sept. 22'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb49461').mouseenter(function() {
   											jQuery('#grow-stb49461').removeClass('shrink');
   											jQuery('#grow-stb49461').removeClass('grow');
   											jQuery('#grow-stb49461').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb49461').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Features</p><p class="relatedtitle"><a href="https://theeasterner.org/49461/arts-entertainment-features/139-years-of-education-with-eastern/">139 Years of Education With Eastern</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/49457/carousel/change-of-perspective-of-africana-studies-throughout-the-years-2/#photo'><img src='https://theeasterner.org/wp-content/uploads/2020/06/46-416x475.jpg' id='grow-stb49457'  style='width:70px;min-width:70px;' class='catboxphoto' alt='Above are Black Student Union officers from 1975. The BSU organization was first recognized at EWU in 1968; it focuses on black identity, black unity and black pride.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb49457').mouseenter(function() {
   											jQuery('#grow-stb49457').removeClass('shrink');
   											jQuery('#grow-stb49457').removeClass('grow');
   											jQuery('#grow-stb49457').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb49457').addClass('shrink');
   										});});</script><p class='stb-cat'>Academic Campus Programs</p><p class="relatedtitle"><a href="https://theeasterner.org/49457/carousel/change-of-perspective-of-africana-studies-throughout-the-years-2/">Change of Perspective of Africana Studies throughout the years</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/49446/arts-entertainment-features/weekly-entertainment-is-back/#photo'><img src='https://theeasterner.org/wp-content/uploads/2018/09/Logan-Richardson-475x267.jpg' id='grow-stb49446'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Jazz musician Logan Richardson. Richardson has collaborated on over 30 albums.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb49446').mouseenter(function() {
   											jQuery('#grow-stb49446').removeClass('shrink');
   											jQuery('#grow-stb49446').removeClass('grow');
   											jQuery('#grow-stb49446').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb49446').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Features</p><p class="relatedtitle"><a href="https://theeasterner.org/49446/arts-entertainment-features/weekly-entertainment-is-back/">Weekly entertainment is back</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/49435/carousel/ewu-music-takes-the-air-kpbxs-piano-bench/#photo'><img src='https://theeasterner.org/wp-content/uploads/2019/11/assembling-the-ensemble-475x295.jpg' id='grow-stb49435'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Members of the EWU music department.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb49435').mouseenter(function() {
   											jQuery('#grow-stb49435').removeClass('shrink');
   											jQuery('#grow-stb49435').removeClass('grow');
   											jQuery('#grow-stb49435').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb49435').addClass('shrink');
   										});});</script><p class='stb-cat'>Academic Campus Programs</p><p class="relatedtitle"><a href="https://theeasterner.org/49435/carousel/ewu-music-takes-the-air-kpbxs-piano-bench/">EWU Music Takes The Air: KPBX’s Piano Bench</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/49419/arts-entertainment-features/sounds-of-spokane-arts-entertainment/all-right-buddy-jokes-over-a-return-of-entertainment-in-spokane/#photo'><img src='https://theeasterner.org/wp-content/uploads/2021/03/comedy-club-covid-graphic-01-475x285.png' id='grow-stb49419'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='People are excited for new sights and sounds in the COVID-19 pandemic. Spokane Comedy Club’s first shows sold out within 2 hours!'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb49419').mouseenter(function() {
   											jQuery('#grow-stb49419').removeClass('shrink');
   											jQuery('#grow-stb49419').removeClass('grow');
   											jQuery('#grow-stb49419').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb49419').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Features</p><p class="relatedtitle"><a href="https://theeasterner.org/49419/arts-entertainment-features/sounds-of-spokane-arts-entertainment/all-right-buddy-jokes-over-a-return-of-entertainment-in-spokane/">All Right Buddy, Joke’s Over: A Return of Entertainment in Spokane</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/49402/arts-entertainment-features/programs-for-black-history-month-at-ewu/#photo'><img src='https://theeasterner.org/wp-content/uploads/2020/06/Screen-Shot-2020-06-03-at-4.24.50-PM-475x318.jpg' id='grow-stb49402'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Dr. Bartlett discusses the importance of Black History Month at Eastern.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb49402').mouseenter(function() {
   											jQuery('#grow-stb49402').removeClass('shrink');
   											jQuery('#grow-stb49402').removeClass('grow');
   											jQuery('#grow-stb49402').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb49402').addClass('shrink');
   										});});</script><p class='stb-cat'>Academic Campus Programs</p><p class="relatedtitle"><a href="https://theeasterner.org/49402/arts-entertainment-features/programs-for-black-history-month-at-ewu/">Programs for Black History Month at EWU</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/49397/arts-entertainment-features/history-behind-africana-studies-and-the-black-student-union-at-ewu/#photo'><img src='https://theeasterner.org/wp-content/uploads/2020/06/BSU-475x356.jpg' id='grow-stb49397'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Members of EWU's Black Student Union, Africana Studies Department and other Eastern students advocated race and diversity education on campus through a protest held on Nov. 3, 2020.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb49397').mouseenter(function() {
   											jQuery('#grow-stb49397').removeClass('shrink');
   											jQuery('#grow-stb49397').removeClass('grow');
   											jQuery('#grow-stb49397').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb49397').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Features</p><p class="relatedtitle"><a href="https://theeasterner.org/49397/arts-entertainment-features/history-behind-africana-studies-and-the-black-student-union-at-ewu/">History behind Africana Studies and the Black Student Union at EWU</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/49359/arts-entertainment-features/ewu-defeats-sac-state-twice-for-first-sweep-of-the-season/#photo'><img src='https://theeasterner.org/wp-content/uploads/2021/02/21mbcaGrovesTanner9105-475x267.jpg' id='grow-stb49359'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='EWU defeats Sac State twice for first sweep of season'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb49359').mouseenter(function() {
   											jQuery('#grow-stb49359').removeClass('shrink');
   											jQuery('#grow-stb49359').removeClass('grow');
   											jQuery('#grow-stb49359').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb49359').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Features</p><p class="relatedtitle"><a href="https://theeasterner.org/49359/arts-entertainment-features/ewu-defeats-sac-state-twice-for-first-sweep-of-the-season/">EWU defeats Sac State twice for first sweep of season</a></p></li></ul></div><div class="stb_nav"><div class="custom-navigation"><span class="flex-next"><div class="stb_right"><div class="fa fa-angle-right"><div class="icon-hidden-text">Navigate Right</div></div></div></span></div></div></div><div class="clear"></div><script type="text/javascript" charset="utf-8">
		jQuery(document).ready(function() {
			jQuery('#stb-container').flexslider({
				animation: "slide",
				animationLoop: true,
				customDirectionNav: jQuery(".stb_nav .custom-navigation span"), 
       			slideshow: false,
				itemMargin: 2,
				touch: true,
				itemWidth: 250,
				minItems: 1,
				move: 1,
				maxItems: 5
  			});

		});

			jQuery(document).ready(function(){
			
			var TB_CurrentScroll = 0; var TB_NextScroll = 0; var hbheight = 0;
			
			
			jQuery(window).scroll(function(event) {
				TB_CurrentScroll = TB_NextScroll;
				if (jQuery('#sno_hoverbar').is(":visible")) { hbheight = 50 }
				TB_NextScroll = jQuery(this).scrollTop();
				if (TB_NextScroll < TB_CurrentScroll && jQuery(document).scrollTop() > 500) {  // scrolling up on the page causes it to display
					if (jQuery('.sno_teaserbar').is(":hidden")) {
						jQuery('.sno_teaserbar').show();
						jQuery('.sno_teaserbar').stop().animate({ top: hbheight }, { duration: 300, queue: false });
					}
				}
				 else if ((TB_NextScroll > TB_CurrentScroll && jQuery(document).scrollTop() > 500) || jQuery(document).scrollTop() < 400 ){ // scrolling down on the page causes it to hide
					jQuery('.sno_teaserbar').stop().animate({
						top: '-86px'
						},200, function(){
							jQuery('.sno_teaserbar').hide();
						});
				} 
			});
				});
	</script></div></div></div></div><div style="clear:both;"></div><div class="footeradboardwrap">
	<div id="footeradboard">
		<div class="footerad snoads_footerad">
			<script type="text/javascript">
				jQuery(document).ready(function( $ ) {
					retreive_ad();
					$('.footerad').on('click', '.sno-ad', function() {
						let ad_id = $(this).data('ad-id');
						var url = 'https://snoads.com/api/v1/ad/' + ad_id + '/click';
						jQuery.post(url, '', function(response) {
							console.log(response);
				        });
					});

					$('.footerad').on('click', '.sno-fill-ad', function() {
						url = 'https://snoads.com/site/467';
						window.open(url, '_blank');
					});

			        function retreive_ad() {
			        	var url = 'https://snoads.com/api/v1/adspot/1304/serve'
			        	var ad_fill = "";
						jQuery.get(url, '', function(response) {
							console.log(response);
							if (response) {
								$('.footeradboardwrap .footerad').html('<a target="_blank" href="' + response.link.link + '" class="sno-ad" data-ad-id="' + response.id + '"><img src="' + response.image.url + '" alt="Advertisement" /></a>');
							} else if (ad_fill) {
								$('.footeradboardwrap .footerad').html('<img class="sno-fill-ad" src="' + ad_fill + '" alt="Advertisement"/>');
							} else {
								let rand_num = Math.floor((Math.random() * 3) + 1);
								$('.footeradboardwrap .footerad').html('<img class="sno-fill-ad" src="https://snoads.s3.amazonaws.com/sno_ad_fill/728x90_' + rand_num + '.jpg" alt="Advertisement"/>');
							}
				        });
			        }
				});
			</script>
		</div>
	</div>
</div><div class="footerwrap footer_single"><div id="footer"><div class="footername"><div class="footerleft"><p><a href="https://theeasterner.org">The Easterner</a></p></div><div class="footerright footer-icon"><style>.topnavbarleft { padding: 0px; width:auto; }</style>    
        								   	    										
    
        				
   	    
    
    		<a target="_blank" href="https://www.youtube.com/user/EasternerFilms">
    		<div class="sno-icon social-border sno-youtube">
        		<i class="fa fa-youtube-play"></i>
        		<span class="icon-hidden-text">YouTube</span>
        	</div>
    	</a>
    
        				
        				    					
        				
						
	    				
    
	
	    
	
	    	<a target="_blank" href="https://www.instagram.com/the_easterner/?hl=en">
    		<div class="sno-icon social-border sno-instagram">
        		<i class="fa fa-instagram"></i>
        		<span class="icon-hidden-text">Instagram</span>
        	</div>
    	</a>
	    				
    		<a target="_blank" href="https://twitter.com/_TheEasterner">
    		<div class="sno-icon social-border sno-twitter">
        		<i class="fa fa-twitter"></i>
        		<span class="icon-hidden-text">Twitter</span>
        	</div>
    	</a>
        				
	    	<a target="_blank" href="https://www.facebook.com/TheEasterner/">
    		<div class="sno-icon social-border sno-facebook">
        		<i class="fa fa-facebook-f"></i>
        		<span class="icon-hidden-text">Facebook</span>
        	</div>
    	</a>
   
   <div class="social-spacer"></div>
   
   </div></div><div class="footertagline"><p>The independent, student-run news site of Eastern Washington University.</p></div><div class="footersearch">	<form method="get" id="searchform7677" action="https://theeasterner.org/">
			<div class="search-button-container" id="searchthis7677">
			<button type="submit" disabled="disabled" id="sno-search-navbar-7677" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s7677" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s7677" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit7677" style="display:none;" value="Search" />
		</form>
	</div><div class="clear"></div><div class="footermenu"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-37720" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37720"><a href="https://theeasterner.org/about/">About The Easterner</a></li>
<li id="menu-item-37721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37721"><a href="https://theeasterner.org/about/contact-us/">Contact Us</a></li>
</ul></div></div><div class="footercredit"><p><a href="http://www.easterneronline.com">The Easterner</a> &bull; &copy; 2021  &bull; <a target='_blank' href='https://snoads.com/site/467'>Advertise</a> &bull;  <a href='https://snosites.com/why-sno/'>FLEX WordPress Theme</a> by <a href='http://snosites.com'>SNO</a> &bull; <a rel="nofollow" href="https://theeasterner.org/wp-login.php">Log in</a></p></div><div class="clear"></div></div></div>
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-53299197-5', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
		
	<div class='remodal-story-image' data-remodal-id='modal-photo' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close sno-overlay-close"><span class="icon-hidden-text">Close</span></button><div class="remodal-inner-container"></div></div><div class="remodal-share-story" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false"><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button><div class="remodal-share-inner-container"></div></div><script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/theeasterner.org\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://theeasterner.org/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/theeasterner.org\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.6' id='wp-polls-js'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script>
</div><div id="sno_hoversearch"><div class="sno-search-close"style="float:right;"><i class="fas fa-times"></i></div><div class="hover-search-area"><form method="get" id="searchform-alt" action="https://theeasterner.org/">
											<label for="s-alt" class="assistive-text">Search</label>
											<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
											<input type="submit" class="submit" name="submit" id="searchsubmit-alt" value="Search" />
											<button type="submit" id="sno-hover-search-button" class="sno-submit-search sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
										</form></div></div><div id="sno_hoverbar"><div class="hoverheader"><div id="search-top"><div class="sno-search-button"><i class="fa fa-search"></i><span class="icon-hidden-text">Activate Search</span></div></div><div class="socialmedia"><div class="sharing sharing-top" data-story-id="49523"><a class='commentscroll' href='https://theeasterner.org/49523/arts-entertainment-features/baseball-is-back/#respond ' title='Jump to Comments'><div class='sharing-icon sno-comments  sharing-mobile-hide'><i class='fa fa-comments-o'></i><span class='icon-hidden-text'>Jump to Comments</span></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ftheeasterner.org%2F49523%2Farts-entertainment-features%2Fbaseball-is-back%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook sharing-mobile-hide"><i class="fa fa-facebook-f"></i><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Baseball is Back!&amp;url=https%3A%2F%2Ftheeasterner.org%2F%3Fp%3D49523" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter sharing-mobile-hide"><i class="fa fa-twitter"></i><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email sharing-mobile-hide"><i class="fa fa-envelope"></i><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//theeasterner.org/49523/arts-entertainment-features/baseball-is-back/?print=true"><div class="sharing-icon sno-print sharing-mobile-hide"><i class="fa fa-print"></i><span class="icon-hidden-text">Print</span></div></a></div><div class="sharing-clear"></div></div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div class="sno-arrow-up"><i class="fa fa-arrow-up"></i><span class="icon-hidden-text">Scroll to Top</span></div></a></div><div class="lf_headerleft"><a href="/"><img src="https://theeasterner.org/wp-content/uploads/2019/02/Screen-Shot-2019-02-11-at-9.07.46-AM.png" alt="The independent, student-run news site of Eastern Washington University." /></a></div><div class="hover_title"><div class="hover_titletext">Baseball is Back!</div><span id="progress-bar"><span id="progress-bar-color"></span></span></div></div><div class="clear"></div></div><div id="hoverbar_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search"><form method="get" class="searchform-alt-left" action="https://theeasterner.org/">
									<label for="s-alt-left-hoverbar" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left-hoverbar" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-mobile-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49073"><a href="https://theeasterner.org/current-issue/">Current Issue</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49074"><a href="https://theeasterner.org/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49075"><a href="https://theeasterner.org/category/arts-entertainment-features/">Arts &amp; Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49076"><a href="https://theeasterner.org/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49077"><a href="https://theeasterner.org/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49078"><a href="https://theeasterner.org/category/multimedia/">Multimedia</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49079"><a href="https://theeasterner.org/category/2020-elections/">2020 Elections</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49080"><a href="https://theeasterner.org/about/">About The Easterner</a></li>
</ul></div></ul></div><script type="text/javascript">
			jQuery(document).ready(function(){
				
	
				function sharingIconsResize() {
					if (jQuery(window).width() < 850) {
						var socialwidth;
						var count = jQuery("#mobile-socialmedia .sharing-mobile-show").length;
						if (count != 0) {
							socialwidth = 100 / count;
							jQuery('#mobile-socialmedia .sharing-icon').width(socialwidth + '%');
						}
					} else {
						jQuery('#sno_hoverbar .sharing-icon').width('50px');
					}
				}
								
				jQuery('.sno-search-button').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '0' });
					jQuery('#s-alt').focus();
				});
				jQuery('.sno-search-close').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '-50px' });
				});
	
				var NavScrollTop		= jQuery(window).scrollTop();
	    		
	    		if( jQuery('.navbarwrap').length ) {
	    			var	TopNavOffset 		= jQuery('.navbarwrap').offset().top;
					var TopNavDistance		= (TopNavOffset - NavScrollTop);
	   	 		}
	   	 		if( jQuery('.subnavbarwrap').length ) {
		   	 		var	BottomNavOffset 	= jQuery('.subnavbarwrap').offset().top;
		   	 		var	BottomNavDistance	= (BottomNavOffset - NavScrollTop);
	   	 		}
	   	 		
	   	 		jQuery('#hoverbar_menu .mobile-menu').height( jQuery(window).height() - 50);
	   	 		
	   	 		var HoverOffset = 0, HoverOffset2 = 0;
					   	 		var HoverHeight = jQuery('#sno_hoverbar').outerHeight();
	   	 		var HoverHeight2 = jQuery('#sno_hoverbar').outerHeight();
	   	 		
					
				var CurrentScroll = 0;
				var WindowHeight = jQuery(document).height() - jQuery('.footerwrap').height();
				
									WindowHeight -= jQuery('#commentswrap').height();		
								
				
/*
				jQuery('.sno-menu').click(function() {
				
					jQuery('#hoverbar_menu').fadeToggle();
					jQuery('.menu-icon').toggle();
					jQuery('.close-icon').toggle();
					jQuery('#hoverbar_menu').css({ height: jQuery(window).height() - 50 });
				
				});
*/
				
				jQuery(window).scroll(function(event) {
					var NextScroll = jQuery(this).scrollTop();
	
					var ScrollPercent = (NextScroll / (WindowHeight - jQuery(window).height())) * 100;
					
	
					jQuery('#progress-bar-color').css({ width: ScrollPercent + '%'});
					jQuery('#hoverbar_menu').css({ top: jQuery('#sno_hoverbar').height() });
					
/*
					if ( ScrollPercent > 100 ) {
												jQuery('.sno-arrow-up').css({ background: '#ca2a1d', color: '#eee'});
						jQuery('.sno-menu').css({ background: '#ca2a1d', color: '#eee'});
						jQuery('.socialmedia .sharing-icon').css({ opacity: 1 })
						
							
					} else {
												jQuery('.sno-arrow-up').css({ background: '#eee', color: '#ccc'});
						jQuery('.sno-menu').css({ background: '#eee', color: '#ccc'});
					}
*/
					var headerLocation = jQuery("#wrap").offset().top;
					if (NextScroll > CurrentScroll && jQuery(document).scrollTop() > headerLocation) {
						if (jQuery('#sno_hoverbar').is(":hidden")) {
							jQuery('#sno_hoverbar').show();
							jQuery('#sno_hoverbar').stop().animate({ top: '0' }, { duration: 300, queue: false });
								
															if( jQuery('.subnavbarwrap').length ) {	
									jQuery('.subnavbarwrap').stop().animate({ top: HoverHeight2 +'px'}, { duration: 300, queue: false });
								}
														
															var lpb = jQuery('.lf_headerleft').width();
																var rpb = 50 + jQuery('.socialmedia').width();
																	rpb += jQuery('#sno_hoverbar .sno-search-button').width();
																jQuery('#progress-bar').css({ left: lpb + 'px', right: rpb + 'px'})
								        			}
	
	
	        			
					} else if (NextScroll < CurrentScroll && jQuery(document).scrollTop() < ( headerLocation + 300 ) && jQuery('#sno_hoverbar').is(":visible")) {
						
							jQuery('#hoverbar_menu').hide();
							jQuery('.close-icon').hide();
							jQuery('.menu-icon').show();
							jQuery('#hoverbar_menu').hide();
							jQuery('#sno_hoverbar').stop().animate({
								top: '-50px'
								},300, function(){
									jQuery('#sno_hoverbar').hide();
								});
							if ( jQuery('.navbarwrap').length ) { jQuery('.navbarwrap').stop().animate({ top: HoverOffset + 'px'},300); }
							if ( jQuery('.subnavbarwrap').length ) { jQuery('.subnavbarwrap').stop().animate({ top: HoverOffset2 + 'px'},300); }
	
					}
				CurrentScroll = NextScroll;
				});
	
	
			});
	
		</script></body></html>