<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> 
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="language" content="en, sv" />
<meta name="viewport" content="width=device-width" /> 			<script type="text/javascript">
			var addToHomeConfig = {
			expire: 10000,
			touchIcon: true
		};
		</script>
		
		<script type="application/javascript" src="https://theeasterner.org/wp-content/themes/snoflex/tools/addtohome/add2home.js"></script>
		<meta name="apple-mobile-web-app-capable" content="yes">
	<link rel="apple-touch-icon" href="https://www.easterneronline.com.php53-12.ord1-1.websitetestlink.com/wp-content/uploads/2014/06/iPAD-Icon.jpg" /><link rel="Shortcut Icon" href="/wp-content/uploads/2014/06/Favicon.jpg" type="image/x-icon" />
<link rel="alternate" type="application/rss+xml" title="The Easterner RSS 2.0" href="https://theeasterner.org/feed/" />
<link rel="alternate" type="text/xml" title="The Easterner RSS .92" href="https://theeasterner.org/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="The Easterner Atom 0.3" href="https://theeasterner.org/feed/atom/" />


<style type="text/css" media="all">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</style><style type="text/css" media="screen">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</style><style type="text/css" media="print">.printfriendly{display:none}</style><title>Ready or not, here comes a Roos renovation - The Easterner</title>

<!-- This site is optimized with the Yoast SEO plugin v11.9 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://theeasterner.org/46578/carousel/ready-or-not-here-comes-a-roos-renovation/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Ready or not, here comes a Roos renovation - The Easterner" />
<meta property="og:description" content="EWU announced plans on Friday, Sept. 6 to move forward with a $25 million renovation of its football stadium. The EWU Board of Trustees unanimously approved the proposal. The project will be funded through private donations and fundraising, not through state funds or student fees. “Eagle Nation deserves a space that matches the strength, passion..." />
<meta property="og:url" content="https://theeasterner.org/46578/carousel/ready-or-not-here-comes-a-roos-renovation/" />
<meta property="og:site_name" content="The Easterner" />
<meta property="article:tag" content="ewu" />
<meta property="article:tag" content="EWU football" />
<meta property="article:tag" content="Football" />
<meta property="article:tag" content="roos field" />
<meta property="article:tag" content="sports" />
<meta property="article:tag" content="stadium renovation" />
<meta property="article:section" content="Carousel" />
<meta property="article:published_time" content="2019-09-07T03:44:53-07:00" />
<meta property="article:modified_time" content="2019-09-07T03:58:30-07:00" />
<meta property="og:updated_time" content="2019-09-07T03:58:30-07:00" />
<meta property="og:image" content="https://theeasterner.org/wp-content/uploads/2019/09/Stadium-Pano.jpg" />
<meta property="og:image:secure_url" content="https://theeasterner.org/wp-content/uploads/2019/09/Stadium-Pano.jpg" />
<meta property="og:image:width" content="1501" />
<meta property="og:image:height" content="605" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="EWU announced plans on Friday, Sept. 6 to move forward with a $25 million renovation of its football stadium. The EWU Board of Trustees unanimously approved the proposal. The project will be funded through private donations and fundraising, not through state funds or student fees. “Eagle Nation deserves a space that matches the strength, passion..." />
<meta name="twitter:title" content="Ready or not, here comes a Roos renovation - The Easterner" />
<meta name="twitter:image" content="https://theeasterner.org/wp-content/uploads/2019/09/Stadium-Pano.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://theeasterner.org/#website","url":"https://theeasterner.org/","name":"The Easterner","potentialAction":{"@type":"SearchAction","target":"https://theeasterner.org/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://theeasterner.org/46578/carousel/ready-or-not-here-comes-a-roos-renovation/#primaryimage","url":"https://theeasterner.org/wp-content/uploads/2019/09/Stadium-Pano.jpg","width":1501,"height":605},{"@type":"WebPage","@id":"https://theeasterner.org/46578/carousel/ready-or-not-here-comes-a-roos-renovation/#webpage","url":"https://theeasterner.org/46578/carousel/ready-or-not-here-comes-a-roos-renovation/","inLanguage":"en-US","name":"Ready or not, here comes a Roos renovation - The Easterner","isPartOf":{"@id":"https://theeasterner.org/#website"},"primaryImageOfPage":{"@id":"https://theeasterner.org/46578/carousel/ready-or-not-here-comes-a-roos-renovation/#primaryimage"},"datePublished":"2019-09-07T03:44:53-07:00","dateModified":"2019-09-07T03:58:30-07:00","author":{"@id":"https://theeasterner.org/#/schema/person/0a84cdff7fb8904a2b51fffe9d3279e6"}},{"@type":["Person"],"@id":"https://theeasterner.org/#/schema/person/0a84cdff7fb8904a2b51fffe9d3279e6","name":"Dylan Harris","image":{"@type":"ImageObject","@id":"https://theeasterner.org/#authorlogo","url":"https://secure.gravatar.com/avatar/6f9d700da7d9c941a7c400482c383071?s=96&d=retro&r=g","caption":"Dylan Harris"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="The Easterner &raquo; Ready or not, here comes a Roos renovation Comments Feed" href="https://theeasterner.org/46578/carousel/ready-or-not-here-comes-a-roos-renovation/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/theeasterner.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.3"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		
			
	









<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Brawler%3A400%2C700%7CPT+Sans%3A400%2C700&#038;ver=5.2.3' type='text/css' media='all' />









<script type='text/javascript' src='https://theeasterner.org/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/javascript/remodal.min.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/javascript/menus-init.js?ver=20190826'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/themes/snoflex/javascript/sno-image-effects.js?ver=20190209'></script>
<link rel='https://api.w.org/' href='https://theeasterner.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://theeasterner.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://theeasterner.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.3" />
<link rel='shortlink' href='https://theeasterner.org/?p=46578' />
<link rel="alternate" type="application/json+oembed" href="https://theeasterner.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheeasterner.org%2F46578%2Fcarousel%2Fready-or-not-here-comes-a-roos-renovation%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://theeasterner.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheeasterner.org%2F46578%2Fcarousel%2Fready-or-not-here-comes-a-roos-renovation%2F&#038;format=xml" />
    
           
		</style>
        


<!-- Start of Facebook Meta Tags -->

<meta property="og:title" content="Ready or not, here comes a Roos renovation" />
<meta property="og:type" content="article" />
<meta name="author" content="Dylan Harris" />
<meta property="og:url" content="https://theeasterner.org/46578/carousel/ready-or-not-here-comes-a-roos-renovation/" />
<meta property="og:image" content="https://theeasterner.org/wp-content/uploads/2019/09/Stadium-Pano-900x363.jpg" />
	<meta property="og:image:width" content="900" />
	<meta property="og:image:height" content="363" />
	<meta property="og:site_name" content="The Easterner" />
	<meta property="og:description" content="EWU announced plans on Friday, Sept. 6 to move forward with a $25 million renovation of its football stadium. The EWU Board of Trustees unanimously approved the proposal. The project will be funded through private donations and fundraising, not through state funds or student fees. “Eagle Nation deserves a space that matches the strength, passion..." />
	<meta name="description" content="EWU announced plans on Friday, Sept. 6 to move forward with a $25 million renovation of its football stadium. The EWU Board of Trustees unanimously approved the proposal. The project will be funded through private donations and fundraising, not through state funds or student fees. “Eagle Nation deserves a space that matches the strength, passion..." />
	<meta property="article:section" content="Carousel" />
	<meta property="article:tag" content="ewu,EWU football,Football,roos field,sports,stadium renovation" />
<!-- End of Facebook Meta Tags -->

<script src="/wp-content/themes/snoflex/parallax/js/skrollr.js"></script>

<script>
	jQuery(document).ready(function() {
		var wpadminbar = jQuery('#wpadminbar').outerHeight();
		if (wpadminbar == null) { var wpadminbar = 0; }
		if (jQuery('#wpadminbar').is(":hidden")) { wpadminbar = 0; }

	
				jQuery('.subnavbarwrap').scrollToFixed({
			marginTop:  wpadminbar,
		});		
		
		
		
	
	});
</script>



</head>

<body data-rsssl=1><div class="leaderboardwrap">
	<div id="leaderboard">
	<div class="leaderboardadwrap" style="margin:0px auto;float:none;">
		 </div>
	 
	 	
	</div>
</div>
<div id="sno_mobile_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search-side"><div class="sno-side-menu side-close-icon foundation-icons fi-x"><span class="icon-hidden-text">Close Menu</span></div><form method="get" class="searchform-alt-left" action="https://theeasterner.org/">
									<label for="s-alt-left" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-main-navigation" class="menu"><li id="menu-item-176" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-176"><a href="https://theeasterner.org/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-43567" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43567"><a href="https://theeasterner.org/category/news/police-beat/">Police Beat</a></li>
	<li id="menu-item-43947" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43947"><a href="https://theeasterner.org/category/election-guide-2018/">Election Guide 2018</a></li>
</ul>
</li>
<li id="menu-item-38612" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38612"><a href="https://theeasterner.org/category/arts-entertainment-features/">A&#038;F</a></li>
<li id="menu-item-37719" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-37719"><a href="https://theeasterner.org/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-46074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46074"><a href="https://theeasterner.org/category/sports/basketball/">Basketball</a></li>
	<li id="menu-item-46075" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-46075"><a href="https://theeasterner.org/category/sports/football/">Football</a></li>
	<li id="menu-item-46076" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46076"><a href="https://theeasterner.org/category/sports/track-and-field/">Track and field</a></li>
</ul>
</li>
<li id="menu-item-177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-177"><a href="https://theeasterner.org/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-43561" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43561"><a href="https://theeasterner.org/category/opinion/easterner-asks/">Easterner asks</a></li>
	<li id="menu-item-46077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46077"><a href="https://theeasterner.org/category/opinion/letters-to-the-editor/">Letters To The Editor</a></li>
</ul>
</li>
<li id="menu-item-43207" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43207"><a href="https://theeasterner.org/category/editorial/">Editorial</a></li>
<li id="menu-item-38813" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-38813"><a href="https://theeasterner.org/category/multimedia/">Multimedia</a>
<ul class="sub-menu">
	<li id="menu-item-45092" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45092"><a href="https://theeasterner.org/category/multimedia/looking-back/">Looking Back</a></li>
	<li id="menu-item-43211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43211"><a href="https://theeasterner.org/category/multimedia/slideshow/">Slideshow</a></li>
	<li id="menu-item-43216" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43216"><a href="https://theeasterner.org/category/multimedia/audio/">Audio</a></li>
</ul>
</li>
<li id="menu-item-46453" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46453"><a href="https://theeasterner.org/category/2018-19-eags-of-the-year/">2018-19 Eags of the Year</a></li>
</ul></div></ul></div><div id="wrap" class="bodywrap"><div id="mobile-menu"><div class="sitetitle"><div class="headerlink headersmall" style="display:none"><img src="/wp-content/uploads/2018/09/85510_Header-01.jpg" class="headerimage" alt="The independent, student-run news site of Eastern Washington University." /></div><div class="headerlink headermedium" style="display:none"><img src="/wp-content/uploads/2018/09/85510_Header-01.jpg" class="headerimage" alt="The independent, student-run news site of Eastern Washington University." /></div><div class="headerlink headerlarge"><img src="/wp-content/uploads/2018/09/85510_Header-01.jpg" class="headerlink headerimage" alt="The independent, student-run news site of Eastern Washington University." /></div><h1 style="display:none" aria-hidden="true">The Easterner</h1><script type="text/javascript">
						jQuery(document).ready(function(){
							jQuery(".headerlink").click(function(){
								window.location="https://theeasterner.org";

							});
						});
					</script><div id="hover-menu-side"><div class="sno-menu-side menu-icon dashicons dashicons-menu"><span class="icon-hidden-text">Menu</span></div></div></div><div class="clear"></div></div><div class="topnavwrap">
	<div id="topnavbar">
			
			<div class="search-spacer"></div>

			<div class="topnavbarleft social-classic">
				<a target="_blank" href="https://www.youtube.com/user/EasternerFilms">
        		<div class="alt-header-social-fa social-border sno-youtube fa fa-youtube"><span class="icon-hidden-text">YouTube</span></div>
        	</a><a target="_blank" href="https://www.instagram.com/the_easterner/?hl=en">
        		<div class="alt-header-social-fa social-border sno-instagram fa fa-instagram"><span class="icon-hidden-text">Instagram</span></div>
        	</a><a target="_blank" href="https://twitter.com/_TheEasterner">
        		<div class="alt-header-social social-border sno-twitter dashicons dashicons-twitter"><span class="icon-hidden-text">Twitter</span></div>
        	</a><a target="_blank" href="https://www.facebook.com/TheEasterner/">
        		<div class="alt-header-social social-border sno-facebook dashicons dashicons-facebook-alt"><span class="icon-hidden-text">Facebook</span></div>
        	</a><div class="social-spacer"></div>			</div>

			<div class="topnavbarcenter">
        			</div>
	
			<div class="topnavbarright">
					<form method="get" id="searchform2416" action="https://theeasterner.org/">
			<div class="search-button-container" id="searchthis2416">
			<button type="submit" disabled="disabled" id="sno-search-navbar-2416" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s2416" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s2416" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit2416" style="display:none;" value="Search" />
		</form>
				</div>
	</div>
	<div class="clear"></div>
</div><div class="headerwrap"><div id="header" style="position:relative;"><div class="headerlarge"><a href="https://theeasterner.org"><img src="/wp-content/uploads/2018/09/85510_Header-01.jpg" class="headerimage" alt="The independent, student-run news site of Eastern Washington University." /></a></div><h1 style="display:none">The Easterner</h1></div></div><div class="navbarwrap"><div class="navbarcontainer"><div id="navbar"><div id="navbarbackground"><div id="menu-a-menu"><nav aria-label="Secondary Menu"><div class="menu-small-menu-container"><ul id="menu-small-menu" class="sf-menu sno-top-menu"><li id="menu-item-43213" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43213"><a href="https://theeasterner.org/about/">About Us</a></li>
<li id="menu-item-43214" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43214"><a href="https://theeasterner.org/about/staff/">Staff</a></li>
<li id="menu-item-46390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46390"><a href="https://theeasterner.org/current-issue/">Current Issue</a></li>
<li id="menu-item-45085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-45085"><a href="https://theeasterner.org/advertising/">Advertising</a></li>
</ul></div></nav></div><ul id='menu-more-top' class='sf-menu sf-js-enabled sf-shadow' style='display:none'><li id="menu-more-item-top" style="float:left;"><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"> »</span></a>
								<ul id="add-more-top" class="sub-menu"></ul>
								</li>
							</ul></div></div></div></div><div class="clear"></div>
					<script type="text/javascript">
						jQuery('#navbar').css("overflow-y", "hidden");
						jQuery(window).load(function() {
							if (jQuery( window).width() < 980) { return; }	
							resizeMenuTop();
						})
												
						function resizeMenuTop() {
							
							if (jQuery( window).width() < 980) { return; }
	
							var moreWidthTop = 0; var menubufferTop = 0; var minilogoTop = 0;
	
							if (jQuery('#menu-more-top').is(':visible')) { moreWidthTop = jQuery('#menu-more-top').width(); }			
																																				var MenuTopWidth = 970;
															var browserWidth = jQuery(window).width();
								if (browserWidth < MenuTopWidth) MenuTopWidth = browserWidth;
								
							
							if (jQuery('#menu-a-menu').width() + menubufferTop + minilogoTop + moreWidthTop >= MenuTopWidth) 
							{ 
								jQuery('.sno-top-menu > li:last-child').addClass('sub-menu'); 
								jQuery('.sno-top-menu > li:last-child').appendTo('#add-more-top'); 
								if (jQuery('#menu-more-top').is(':hidden')) { jQuery('#menu-more-top').css({display: "block"}); }			
								if (jQuery('#menu-a-menu').width() + menubufferTop + minilogoTop + moreWidthTop > MenuTopWidth) {
									resizeMenuTop(); 
								} else {
									jQuery('#navbar').css("overflow-y", "unset");
									resizeMenuTop(); 
								}
							} else {
								jQuery('#navbar').css("overflow-y", "unset");								
							}
							 
						}
	            		jQuery( window ).resize(function() { 
	             	   		if (jQuery( window).width() > 980) { resizeMenuTop(); };
	            		});   
	 				</script>
	 			<div class="bottom-menu"><div class="subnavbarwrap"><div class="subnavbarcontainer"><div id="subnavbar"><div id="subnavbarbackground"><div id="menu-b-menu"><nav aria-label="Main Menu"><div class="menu-main-navigation-container"><ul id="menu-main-navigation-1" class="sf-menu sno-bottom-menu" role="menubar"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-176" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://theeasterner.org/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43567"><a href="https://theeasterner.org/category/news/police-beat/">Police Beat</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43947"><a href="https://theeasterner.org/category/election-guide-2018/">Election Guide 2018</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38612"><a href="https://theeasterner.org/category/arts-entertainment-features/">A&#038;F</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-37719" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://theeasterner.org/category/sports/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46074"><a href="https://theeasterner.org/category/sports/basketball/">Basketball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-46075"><a href="https://theeasterner.org/category/sports/football/">Football</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46076"><a href="https://theeasterner.org/category/sports/track-and-field/">Track and field</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-177" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://theeasterner.org/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43561"><a href="https://theeasterner.org/category/opinion/easterner-asks/">Easterner asks</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46077"><a href="https://theeasterner.org/category/opinion/letters-to-the-editor/">Letters To The Editor</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43207"><a href="https://theeasterner.org/category/editorial/">Editorial</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-38813" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://theeasterner.org/category/multimedia/">Multimedia</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45092"><a href="https://theeasterner.org/category/multimedia/looking-back/">Looking Back</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43211"><a href="https://theeasterner.org/category/multimedia/slideshow/">Slideshow</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43216"><a href="https://theeasterner.org/category/multimedia/audio/">Audio</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46453"><a href="https://theeasterner.org/category/2018-19-eags-of-the-year/">2018-19 Eags of the Year</a></li>
</ul></div></nav><div class="clear"></div></div><ul id='menu-more-bottom' class='sf-menu sf-js-enabled sf-shadow' style='display:none'><li id="menu-more-item-bottom" style="float:left;"><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"> »</span></a>
						<ul id="add-more-bottom" class="sub-menu"></ul>
						</li>
					</ul></div><div class="clear"></div></div></div></div></div><div class="clear"></div>					<script type="text/javascript">
						jQuery('#subnavbar').css("overflow-y", "hidden");
						jQuery(window).load(function() {
							if (jQuery( window).width() < 980) { return; }
							resizeMenuBottom();
						})
						
						function resizeMenuBottom() {
							if (jQuery( window).width() < 980) { return; }
							var moreWidth = 0; var menubuffer = 0; var minilogo = 0;
							if (jQuery('#menu-more-bottom').is(':visible')) { moreWidth = jQuery('#menu-more-bottom').width(); }			
																																				var MenuBottomWidth = 970;
															var browserWidth = jQuery(window).width();
								if (browserWidth < MenuBottomWidth) MenuBottomWidth = browserWidth;

							if ((jQuery('#menu-b-menu').width() + menubuffer + minilogo + moreWidth) >= MenuBottomWidth) 
							{ 
								jQuery('.sno-bottom-menu > li:last-child').addClass('sub-menu'); 
								jQuery('.sno-bottom-menu > li:last-child').appendTo('#add-more-bottom'); 
								if (jQuery('#menu-more-bottom').is(':hidden')) { jQuery('#menu-more-bottom').css({display: "block"}); }			
								if ((jQuery('#menu-b-menu').width() + menubuffer + minilogo + moreWidth) > MenuBottomWidth) {
									resizeMenuBottom(); 
								} else {
									jQuery('#subnavbar').css("overflow-y", "unset");
									resizeMenuBottom(); 
								}
							} else {
								jQuery('#subnavbar').css("overflow-y", "unset");
							} 							 
						}
	            		jQuery( window ).resize(function() { 
	             	   		if (jQuery( window).width() > 980) { resizeMenuBottom(); };
	            		});   
	 				</script>
	 			
	 							<script type="text/javascript">
					jQuery(document).ready(function() {
						jQuery(".newsticker3-jcarousellite").jCarouselLite({
        					vertical: true,
        					visible: 1,
        					auto:5000,
        					speed:2000    					});
					});
				</script><div id="fullwrap" style="position:relative;"><div class="innerbackgroundwrap"><div class="innerbackground"><div id='snopostid-46578' class='snopostid'><div id='classic_story' class='sno-story-46578'><div id="content"><div id='contentleft'><div class="postarea"><div role="main"><h1 class="storyheadline">Ready or not, here comes a Roos renovation</h1><div class="storyshadow"><div class="photowrap"><a class='modal-photosingle46578' href='#photo'><img src='https://theeasterner.org/wp-content/uploads/2019/09/Stadium-Pano-900x363.jpg' alt='One+of+the+renderings+of+the+proposed+football+stadium+renovation.+Construction+will+begin+as+soon+as+the+%2425+million+is+raised.' style='width:100%' class='catboxphoto feature-image' /></a><div class='modal-photosingle46578 photo-enlarge elusive el-icon-zoom-in'></div><div class='remodal remodal-story-image sno-single-image' data-remodal-id='modal-photosingle46578' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close</span></button><div class="photo-container"><div class="sfi-header"><div class="sfi-return-to-story" data-remodal-action="cancel"><div class="fa fa-angle-left"><div class="icon-hidden-text">Back to Article</div></div><div class="sfi-back-text">Back to Article</div></div><div class="sfi-title-area"><p class="sfi-title">Ready or not, here comes a Roos renovation</p></div></div><div class='single-photo-wrap single-photo-container slideshow-photo-containersingle46578  sfi_has_caption'><img id="imagesingle46578" src="https://theeasterner.org/wp-content/uploads/2019/09/Stadium-Pano.jpg" alt="One of the renderings of the proposed football stadium renovation. Construction will begin as soon as the $25 million is raised." class="enlarged-photo" data-width="1501" data-height="605"/></div><div class='photo-caption-container'><p class='photocaptionremodal'>One of the renderings of the proposed football stadium renovation. Construction will begin as soon as the $25 million is raised.</p><p class='photocreditremodal'><p class="photocredit">Courtesy of EWU</p></p></div><div class="clear"></div><div class="slideshow-caption-container-tablet"><p class='photocaptionremodal'>One of the renderings of the proposed football stadium renovation. Construction will begin as soon as the $25 million is raised.</p><p class='photocredit'><p class="photocredit">Courtesy of EWU</p></p></div></div></div><script type="text/javascript">
												jQuery(document).ready(function() {
													jQuery(function(){
														jQuery('html').on('click', 'button.remodal-close', function(){
															sno_slideshow_open = 'no';
														});
														jQuery('html').on('click', '.sfi-return-to-story', function(){
															sno_slideshow_open = 'no';
														});
														jQuery('body').keypress(function(e){
															if(e.which == 27 || e.which == 0){
																sno_slideshow_open = 'no';
															}
														});									

														var sno_slideshow_open = 'no';
															jQuery('html').on('wheel', function(event) {
																var delta = {
																	y: event.originalEvent.deltaY
																};
																			
															if (delta.y > 20 && sno_slideshow_open == 'yes') {
																	jQuery('button.remodal-close').trigger('click');
																	sno_slideshow_open = 'no';
																}
															});
															
														jQuery(".modal-photosingle46578").click(function() {
															sno_slideshow_open = 'yes';
															var inst = jQuery("[data-remodal-id=modal-photosingle46578]").remodal();
															inst.open();
															scalephoto();
											//				var slideshow_area_heightsingle46578 = jQuery('.single-photo-container').height(); 
											//				var photo_heightsingle46578 = 605;
											//		
											//				if (photo_heightsingle46578 < slideshow_area_heightsingle46578 ) {
											//					var top_marginsingle46578 = (slideshow_area_heightsingle46578 - photo_heightsingle46578)/2;
											//					jQuery('#imagesingle46578').css("margin-top", top_marginsingle46578);
											//				}
														});
													});

						  							// let's make photos fully fill the frame if they are close to filling the frame and if they are large enough to start with
						  							
						  							function scalephoto() {
							  							jQuery(".slideshow-photo-containersingle46578").each(function(){
								  							photo_w = jQuery(this).find('img').attr('data-width');
								  							photo_h = jQuery(this).find('img').attr('data-height');
								  							if (photo_h > 0) { photo_ratio = photo_w / photo_h; } else { photo_ratio = 2; }
								  							area_w = jQuery(this).width();
								  							area_h = jQuery(this).height();
								  							if (area_h > 0) { area_ratio = area_w / area_h; } else { area_ratio = 2; }
								  							photo_ratio = photo_ratio.toFixed(2); area_ratio = area_ratio.toFixed(2);
								  							ratio_diff = Math.abs(area_ratio - photo_ratio).toFixed(2);
								  							if (ratio_diff < .3 && photo_w > area_w * .7 && photo_h > area_h * .7) {
									  							jQuery(this).find('img').addClass('forcefill');
									  						} else {
									  							jQuery(this).find('img').removeClass('forcefill');
									  						}
							  							})
						  							}
													jQuery(function() {
														scalephoto();
														window.onresize = function() {
															scalephoto();
											            };
													});

												});
										</script></div><div class="clear"></div><div class="captionboxmittop"><p class="photocredit">Courtesy of EWU</p><p class="photocaption">One of the renderings of the proposed football stadium renovation. Construction will begin as soon as the $25 million is raised.</p></div></div><div class="clear"></div><div class="permalinkphotobox"></div><div class="storydetails"><p><span class="storybyline">By <a href="https://theeasterner.org/about/staff/?writer=Dylan%20Harris" class="creditline">Dylan Harris</a>, Managing Editor</span><br /><span class="storydate"><span class="time-wrapper">September 6, 2019</span></span><br /><span class="storycategory">Filed under <a href="https://theeasterner.org/category/carousel/" rel="category tag">Carousel</a>, <a href="https://theeasterner.org/category/sports/football/" rel="category tag">Football</a>, <a href="https://theeasterner.org/category/news/" rel="category tag">News</a>, <a href="https://theeasterner.org/category/sports/" rel="category tag">Sports</a></span></p></div><script type="text/javascript">
					jQuery(function () {
						jQuery('.commentscroll').click(function () {
						var adjustment = 70;
																			adjustment += jQuery('.subnavbarwrap').height();
												jQuery('html, body').animate({ scrollTop: jQuery("#commentswrap").offset().top - adjustment }, 500);
						return false;
						});
					});
				</script><div class="sharing sharing-top"><a class='commentscroll' href='https://theeasterner.org/46578/carousel/ready-or-not-here-comes-a-roos-renovation/#respond'><div class='sharing-icon sno-comments fa fa-comments-o sno-dark  sharing-mobile-hide'></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ftheeasterner.org%2F46578%2Fcarousel%2Fready-or-not-here-comes-a-roos-renovation%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Ready+or+not%2C+here+comes+a+Roos+renovation&amp;url=https%3A%2F%2Ftheeasterner.org%2F%3Fp%3D46578" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a data-remodal-target="modal"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a></div>			<script type="text/javascript">
				jQuery(document).ready(function() {
					jQuery(function($){
						$('.modal-share').click(function() {
							var inst = $('[data-remodal-id=modal-share]').remodal();
							inst.open();

							var sharestoryid = '46578';

							$.ajax({
	                			url:"/wp-admin/admin-ajax.php",
								type:'POST',
								data:'action=sharestory&sharestoryid=' + sharestoryid,
								success:function(results)
	            					{ $(".suggestedstories").replaceWith(results); }
	           				});

						});
										
					});
				});
			</script>

			<div class="remodal" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div class="suggestedstories">
  				<h1>Hang on for a minute...we're trying to find some more stories you might like.</h1>
  				<form method="post" action="">

  				<br />
  				<button data-remodal-action="cancel" class="remodal-cancel">Close</button>

  				</form>
  				</div>
			</div>

					<div class="remodal" data-remodal-id="modal" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div class="emailstoryform">
  				<h1>Email This Story</h1>
  				<form method="post" action="">
  				<label for="email_to_Above" style="display:none;">Send email to this address</label>
  				<input type="text" id="email_to_Above" name="email_to_Above" class="sno_email_fields" placeholder="Send email to this address"><br />
  				
  				<label for="email_from_Above" style="display:none;">Enter Your Name</label>
  				<input type="text" id="email_from_Above" name="email_from_Above" class="sno_email_fields" placeholder="Enter Your Name"><br />
  				
  				<label for="email_comment_Above" style="display:none;">Add a comment here</label>
  				<textarea rows="4" id="email_comment_Above" name="email_comment_Above" class="sno_email_fields" placeholder="Add a comment here (optional)."></textarea><br />
  				
  				<label for="human_Above" style="display:none;">Verification</label>
  				<input type="text" id="human_Above" name="human_Above" class="sno_email_fields" placeholder="What's 7 + 4?"><br />

  				<br />
  				<button id="submit_email_Above" data-remodal-action="confirm" class="remodal-confirm">Send Email</button>
  				<button data-remodal-action="cancel" class="remodal-cancel">Cancel</button>
  				<input type="hidden" id="sno_email_submission_form811628" name="sno_email_submission_form811628" value="fe00e63aec" /><input type="hidden" name="_wp_http_referer" value="/46578/carousel/ready-or-not-here-comes-a-roos-renovation/" />
  				</form>
  				</div>
			</div>
										<script>
								jQuery(document).ready(function() {

								jQuery(function($){
           							$('#submit_email_Above').click(function(){
											var storyid = '46578';
											var datastring = '';
											if ($("#email_to_Above").length > 0){
												var email_to = $('input[name=email_to_Above]');
												datastring += '&email_to=' + encodeURIComponent(email_to.val());
       										}

											if ($("#email_from_Above").length > 0){
												var email_from = $('input[name=email_from_Above]');
												datastring += '&email_from=' + encodeURIComponent(email_from.val());
       										}

											if ($("#email_comment_Above").length > 0){
												var email_comment = $('textarea[name=email_comment_Above]');
												datastring += '&email_comment=' + encodeURIComponent(email_comment.val());
       										}

											if ($("#human_Above").length > 0){
												var human = $('input[name=human_Above]');
												datastring += '&human=' + encodeURIComponent(human.val());
       										}
       										
	   										datastring += '&humanity=' + 11;

       										var verification = $('input[name=sno_email_submission_form811628]');
	   										datastring += '&verification=' + verification.val();
       										
										//	var parentid = '';
               							$.ajax({
                				            url:"/wp-admin/admin-ajax.php",
                				            type:'POST',
                				            data:'action=emailstory&storyid=' + storyid + datastring,
 	            				            success:function(results)
	            				            { $(".emailstoryform").replaceWith(results); }
	           				    	  	});
	         						});
								});
								});

							</script>

			<span class="storycontent"><p>EWU announced plans on Friday, Sept. 6 to move forward with a $25 million renovation of its football stadium. The EWU Board of Trustees unanimously approved the proposal.</p>
<p>The project will be funded through private donations and fundraising, not through state funds or student fees.</p>
<p>“Eagle Nation deserves a space that matches the strength, passion and hard work of a program and is a point of pride throughout the region and beyond,” EWU Athletic Director Lynn Hickey said in a press release. “This is a reasonable plan that will give us that space.”</p>
<p>Stadium renovations are set to begin as soon as the $25 million is raised, beginning with a replacement of the turf. Don’t worry, the turf will still be red. There is no official start date, but EWU hopes to replace the turf before the 2020 season.</p>
<p>The proposed plans include new seats with more leg room, improved concessions and restrooms located closer to the seating areas and additional club seats and suites. The renovation will also feature an expansion of seating on the visitor’s side, and the track around the field will be relocated in order to bring fans closer to the action.</p>
<p>“This has a domino effect,” Hickey said. “We get a new stadium, but our track team also gets a new track. … This is going to have an impact on all our sports and all our students.”</p>
<p>The location of the new track is expected to be on the south side of the P.E. Building, where the soccer and practice fields are located. The stadium’s capacity will be about the same, but the school is hoping to improve the overall experience for fans, players and anyone else at the games with the aforementioned improvements.</p>
<p>Roos Field will not only look different; it may also have a new name.</p>
<p>“We can’t say for sure right now, but there might be some opportunities for other donors as well,” the EWU website reads. “We are very appreciative of what Michael Roos has done for Eastern over the years.”</p>
<p>The EWU football program has become a powerhouse, having won the National Championship in 2010 and making another National Championship appearance just last year, albeit with an undesired outcome. This stadium renovation is intended to reflect that on-field success.</p>
<p>“We are an exciting campus with tremendous athletics, as well as academics,” EWU President Mary Cullinan said. “I’m so proud of our student athletes and they deserve to have facilities that support our greatness.”</p>
<p>For more information regarding the project, visit ewu.edu/stadium. The Easterner will continue to follow this story as more updates are made available.</p>
<div class="printfriendly pf-alignleft"><a href="#" rel="nofollow" onclick="window.print();if(typeof(_gaq) != 'undefined') { _gaq.push(['_trackEvent','PRINTFRIENDLY', 'print', 'NULL']);
          }else if(typeof(ga) != 'undefined') {  ga('send', 'event','PRINTFRIENDLY', 'print', 'NULL'); } return false;" class="noslimstat" title="Printer Friendly, PDF & Email"><img style="border:none;-webkit-box-shadow:none; box-shadow:none;" src="https://cdn.printfriendly.com/buttons/print-button-gray.png" alt="Print Friendly, PDF & Email" /></a></div></span><div class="clear"></div></div><div class="postmeta"><p><span class="tags sno">Tags: <a href="https://theeasterner.org/tag/ewu/" rel="tag">ewu</a>, <a href="https://theeasterner.org/tag/ewu-football/" rel="tag">EWU football</a>, <a href="https://theeasterner.org/tag/football/" rel="tag">Football</a>, <a href="https://theeasterner.org/tag/roos-field/" rel="tag">roos field</a>, <a href="https://theeasterner.org/tag/sports-2/" rel="tag">sports</a>, <a href="https://theeasterner.org/tag/stadium-renovation/" rel="tag">stadium renovation</a></span></p></div><div class="aboutwriter"><div class='aboutwritertitle'>About the Writer</div>
<!-- profile displayed from cache -->
<div class='storycreditboxwide'><div class='sc_photo'><img src='https://theeasterner.org/wp-content/uploads/2018/08/Dylan-1-475x317.jpg' alt='Photo of Dylan Harris'/></div><a href='https://theeasterner.org/about/staff/?writer=Dylan+Harris'><div class='sc_title'>Dylan Harris, News Editor</div></a><div class='sc_bio'><p>Dylan Harris is The Easterner’s news editor. Harris, a senior studying journalism, plans to pursue a career as a news writer after college.</p><div class='clear'></div></div></div><div class="clear"></div></div></div><script>
        		jQuery(document).ready(function() {
    				jQuery("#commentsbox").click(function() {
    			    	jQuery("#commentsbody").slideToggle('slow');
    			    	jQuery("#expand").toggle();
    			    	jQuery("#collapse").toggle();
    				});
				});				
        		jQuery(document).ready(function() {
    				jQuery("#commentslink").click(function() {
    			    	jQuery("#commentsbody").slideDown('slow');
    			    	jQuery("#expand").hide();
    			    	jQuery("#collapse").show();
    				});
				});				
			</script><div id="comments" class="sno-animate" style="height:60px;display:block"></div><div class="clear"></div><div id="commentswrap"><div class="widgetwrap"><div class="titlewrap cursorpoint" id="commentsbox"><div id="expand"><div class="fa fa-plus-square"></div></div><div id="collapse"><div class="fa fa-minus-square"></div></div><div class="widgettitle-nonsno">Leave a Comment</div></div><div id="commentsbody" class="widgetbody">


<!-- You can start editing here. -->



<div id="commentblock">




	
		<!-- If comments are open, but there are no comments. -->



	 








<p id="respond">
The Easterner reserves the right to edit or delete hate speech, inflammatory statements or vulgarities in comments. The Easterner also reserves the right to delete advertising from comments.<br /><br />
If you want a picture to show with your comment, go get a <a href="https://en.gravatar.com">gravatar</a>.</p>





<form action="https://theeasterner.org/wp-comments-post.php" method="post" id="commentform">






<p><label for="name">Name (required)</label><br />

<input type="text" name="author" id="name" value="" size="50" tabindex="1" /></p>



<p><label for="email">Email Address (required)</label><br />

<input type="text" name="email" id="email" value="" size="50" tabindex="2" /></p>








<!--<p><small><strong>XHTML:</strong> You can use these tags: </small></p>-->


<div style="display:none"><label for="spam_stopper">Spam Control Field. Please Ignore</label><input type="text" name="sno_is_legit_comment" id="spam_stopper" value="SNO_Spam_Stopper"/></p></div>

	             		<script type="text/javascript">
							jQuery(function(){
								jQuery('input[name="sno_is_legit_comment"]').attr('name', 'sno_stop_spam');
							});
						</script>


<p><label for="words">Speak your mind</label><br /><textarea name="comment" id="words" cols="40" rows="10" tabindex="4"></textarea></p>



<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />

<input type="hidden" name="comment_post_ID" value="46578" /></p>






</form>









</div></div><div class="widgetfooter"></div></div></div></div><div id="sidebar"><div style="clear:both"></div><section><div class="widgetwrap sno-animate"><div><div id="ad-45674" class="snoadrotatewidgetwrap ad- column-1">
			 
				<a rel="" href="https://theeasterner.org/ads/dunham-manufacturing/" target="_blank"><img src="https://theeasterner.org/wp-content/uploads/2019/04/thumbnail_Eastern-Washington-Univ300X250.jpg" class="centered" style="max-width:100%;"/></a>
	</div><div class="clear clearfix clearboth"></div></div><div class="widgetfooter3"></div></div></section><section><div class='widgetwrap sno-animate sno-page-3' style=''><div class="widget1 widgettitle" role="heading"><a href='https://theeasterner.org/reader-survey/'>Reader Survey</a></div><div class="clear"></div><div class="widgetbody1" style="">
			

						
					<div class="catboxthumbnail" style="float:Left; width: 100%; margin-Left:0px;">						<a href="https://theeasterner.org/reader-survey/"><img src="https://theeasterner.org/wp-content/uploads/2019/01/Section-Graphics_Easterner-Asks-475x296.png" style="width:100%" class="catboxphoto" alt="Reader Survey" /></a>
						</div>						
											
					
			  			<span style="font-size:18px; line-height:27px;"><p>We want to know what our EWU community members (YOU) need from us!

We, as ...</p></span>
   	 					<div style="clear:both"></div>

        			<div class="storybottom"></div>					<a href="https://theeasterner.org/reader-survey/"><p class="viewall">View Page <span class="arrows"> &raquo;</span></p></a>
		
		<div class="widget-expander" style="padding-bottom:0px"></div><div class="clear"></div>

	    </div>
				
				
		</div></section>


<div style="clear:both"></div><section><div class="widgetwrap sno-animate"><div></div><div class="titlewrap" role="heading"><div class="widgettitle-nonsno">Search Easterner Online</div></div><div class="widgetbody">	<form method="get" id="searchform6898" action="https://theeasterner.org/">
			<div class="search-button-container" id="searchthis6898">
			<button type="submit" disabled="disabled" id="sno-search-navbar-6898" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s6898" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s6898" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit6898" style="display:none;" value="Search" />
		</form>
	</div><div class="widgetfooter3"></div></div></section>
<!-- widget displayed from cache -->
<section><div class='widgetwrap  sno-animate sno-category-36' style=''><div style="overflow: hidden;margin-bottom:0px;border-bottom:0px solid #000000;border-top:5px solid #000000;background:#ffffff;"><div class="widget7 widgettitle" role="heading"><a href='/'>Recent Stories</a></div></div><div class="clear"></div><div class="widgetbody7" style=""><div id='catbox-cat3646585' class='catboxthumbsmall' style='margin-left:0px;float:left;'><a href='https://theeasterner.org/46585/sports/dorton-ewu-offense-set-records-in-victory-over-lindenwood/#photo'><img src='https://theeasterner.org/wp-content/uploads/2019/09/IMG_4420-1-315x475.jpg' id='grow-cat3646585'  alt='Dorton, EWU offense set records in victory over Lindenwood' /></a></div><p><a class='homeheadline' style='font-size:16px; line-height: 1.2em;' href='https://theeasterner.org/46585/sports/dorton-ewu-offense-set-records-in-victory-over-lindenwood/'>Dorton, EWU offense set records in victory over Lindenwood</a></p><p><span class="time-wrapper"> September 7, 2019</span></p><p>There's a new wide receiver wearing the No. 10 and breaking records for EWU.

Senior Dre Dorton broke...</p><div class='clear'></div><div style='margin-top:15px'></div><script type='text/javascript'>
								jQuery(document).ready(function() {
   								 	jQuery('#grow-cat3646585').mouseenter(function() {
   										jQuery('#grow-cat3646585').removeClass('shrink');
   										jQuery('#grow-cat3646585').removeClass('grow');
   										jQuery('#grow-cat3646585').addClass('grow');
   									}).mouseleave(function() {
   										jQuery('#grow-cat3646585').addClass('shrink');
  									});
										var original_width = 315;
										var original_height = 475;
										var actual_width = jQuery('#catbox-cat3646585').width();
										if (actual_width == 0) actual_width = original_width;
										var actual_height = (actual_width * original_height) / original_width;
										actual_height = Math.round(actual_height);
										jQuery('#photowrap-cat3646585').css({ maxHeight: actual_height + 'px' });});</script><div id='catbox-cat3646578' class='catboxthumbsmall' style='margin-left:0px;float:left;'><a href='https://theeasterner.org/46578/carousel/ready-or-not-here-comes-a-roos-renovation/#photo'><img src='https://theeasterner.org/wp-content/uploads/2019/09/Stadium-Pano-475x191.jpg' id='grow-cat3646578'  alt='Ready or not, here comes a Roos renovation' /></a></div><p><a class='homeheadline' style='font-size:16px; line-height: 1.2em;' href='https://theeasterner.org/46578/carousel/ready-or-not-here-comes-a-roos-renovation/'>Ready or not, here comes a Roos renovation</a></p><p><span class="time-wrapper"> September 6, 2019</span></p><p>EWU announced plans on Friday, Sept. 6 to move forward with a $25 million renovation of its football...</p><div class='clear'></div><div style='margin-top:15px'></div><script type='text/javascript'>
								jQuery(document).ready(function() {
   								 	jQuery('#grow-cat3646578').mouseenter(function() {
   										jQuery('#grow-cat3646578').removeClass('shrink');
   										jQuery('#grow-cat3646578').removeClass('grow');
   										jQuery('#grow-cat3646578').addClass('grow');
   									}).mouseleave(function() {
   										jQuery('#grow-cat3646578').addClass('shrink');
  									});
										var original_width = 475;
										var original_height = 191;
										var actual_width = jQuery('#catbox-cat3646578').width();
										if (actual_width == 0) actual_width = original_width;
										var actual_height = (actual_width * original_height) / original_width;
										actual_height = Math.round(actual_height);
										jQuery('#photowrap-cat3646578').css({ maxHeight: actual_height + 'px' });});</script><div id='catbox-cat3646555' class='catboxthumbsmall' style='margin-left:0px;float:left;'><a href='https://theeasterner.org/46555/sports/ewu-seeks-red-emption-in-home-opener/#photo'><img src='https://theeasterner.org/wp-content/uploads/2019/09/DSC_3236-e1567718066642-475x187.jpg' id='grow-cat3646555'  alt='EWU seeks red-emption in home opener' /></a></div><p><a class='homeheadline' style='font-size:16px; line-height: 1.2em;' href='https://theeasterner.org/46555/sports/ewu-seeks-red-emption-in-home-opener/'>EWU seeks red-emption in home opener</a></p><p><span class="time-wrapper"> September 5, 2019</span></p><p>The EWU football team didn’t kick off its season with the desired results. After a 47-14 shellacking...</p><div class='clear'></div><div style='margin-top:15px'></div><script type='text/javascript'>
								jQuery(document).ready(function() {
   								 	jQuery('#grow-cat3646555').mouseenter(function() {
   										jQuery('#grow-cat3646555').removeClass('shrink');
   										jQuery('#grow-cat3646555').removeClass('grow');
   										jQuery('#grow-cat3646555').addClass('grow');
   									}).mouseleave(function() {
   										jQuery('#grow-cat3646555').addClass('shrink');
  									});
										var original_width = 475;
										var original_height = 187;
										var actual_width = jQuery('#catbox-cat3646555').width();
										if (actual_width == 0) actual_width = original_width;
										var actual_height = (actual_width * original_height) / original_width;
										actual_height = Math.round(actual_height);
										jQuery('#photowrap-cat3646555').css({ maxHeight: actual_height + 'px' });});</script><div id='catbox-cat3646542' class='catboxthumbsmall' style='margin-left:0px;float:left;'><a href='https://theeasterner.org/46542/sports/football/eagles-thrashed-by-huskies-in-football-opener/#photo'><img src='https://theeasterner.org/wp-content/uploads/2019/08/MG_1128-475x317.jpg' id='grow-cat3646542'  alt='Eagles thrashed by Huskies in football opener' /></a></div><p><a class='homeheadline' style='font-size:16px; line-height: 1.2em;' href='https://theeasterner.org/46542/sports/football/eagles-thrashed-by-huskies-in-football-opener/'>Eagles thrashed by Huskies in football opener</a></p><p><span class="time-wrapper"> August 31, 2019</span></p><p>The EWU football team’s upset bid was quickly snuffed out by the Washington Huskies Saturday in each...</p><div class='clear'></div><div style='margin-top:15px'></div><script type='text/javascript'>
								jQuery(document).ready(function() {
   								 	jQuery('#grow-cat3646542').mouseenter(function() {
   										jQuery('#grow-cat3646542').removeClass('shrink');
   										jQuery('#grow-cat3646542').removeClass('grow');
   										jQuery('#grow-cat3646542').addClass('grow');
   									}).mouseleave(function() {
   										jQuery('#grow-cat3646542').addClass('shrink');
  									});
										var original_width = 475;
										var original_height = 317;
										var actual_width = jQuery('#catbox-cat3646542').width();
										if (actual_width == 0) actual_width = original_width;
										var actual_height = (actual_width * original_height) / original_width;
										actual_height = Math.round(actual_height);
										jQuery('#photowrap-cat3646542').css({ maxHeight: actual_height + 'px' });});</script><div class='widget-expander' style='padding-bottom:0px'></div><div class='clear'></div></div></div></section><div style="clear:both"></div><section><div class="widgetwrap sno-animate"><div></div><div class="titlewrap" role="heading"><div class="widgettitle-nonsno">Archive: 2012-Current</div></div><div class="widgetbody">		<label class="screen-reader-text" for="archives-dropdown-5">Archive: 2012-Current</label>
		<select id="archives-dropdown-5" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://theeasterner.org/date/2019/09/'> September 2019 </option>
	<option value='https://theeasterner.org/date/2019/08/'> August 2019 </option>
	<option value='https://theeasterner.org/date/2019/07/'> July 2019 </option>
	<option value='https://theeasterner.org/date/2019/06/'> June 2019 </option>
	<option value='https://theeasterner.org/date/2019/05/'> May 2019 </option>
	<option value='https://theeasterner.org/date/2019/04/'> April 2019 </option>
	<option value='https://theeasterner.org/date/2019/03/'> March 2019 </option>
	<option value='https://theeasterner.org/date/2019/02/'> February 2019 </option>
	<option value='https://theeasterner.org/date/2019/01/'> January 2019 </option>
	<option value='https://theeasterner.org/date/2018/12/'> December 2018 </option>
	<option value='https://theeasterner.org/date/2018/11/'> November 2018 </option>
	<option value='https://theeasterner.org/date/2018/10/'> October 2018 </option>
	<option value='https://theeasterner.org/date/2018/09/'> September 2018 </option>
	<option value='https://theeasterner.org/date/2018/08/'> August 2018 </option>
	<option value='https://theeasterner.org/date/2018/07/'> July 2018 </option>
	<option value='https://theeasterner.org/date/2018/06/'> June 2018 </option>
	<option value='https://theeasterner.org/date/2018/05/'> May 2018 </option>
	<option value='https://theeasterner.org/date/2018/04/'> April 2018 </option>
	<option value='https://theeasterner.org/date/2018/03/'> March 2018 </option>
	<option value='https://theeasterner.org/date/2018/02/'> February 2018 </option>
	<option value='https://theeasterner.org/date/2018/01/'> January 2018 </option>
	<option value='https://theeasterner.org/date/2017/12/'> December 2017 </option>
	<option value='https://theeasterner.org/date/2017/11/'> November 2017 </option>
	<option value='https://theeasterner.org/date/2017/10/'> October 2017 </option>
	<option value='https://theeasterner.org/date/2017/09/'> September 2017 </option>
	<option value='https://theeasterner.org/date/2017/08/'> August 2017 </option>
	<option value='https://theeasterner.org/date/2017/07/'> July 2017 </option>
	<option value='https://theeasterner.org/date/2017/06/'> June 2017 </option>
	<option value='https://theeasterner.org/date/2017/05/'> May 2017 </option>
	<option value='https://theeasterner.org/date/2017/04/'> April 2017 </option>
	<option value='https://theeasterner.org/date/2017/03/'> March 2017 </option>
	<option value='https://theeasterner.org/date/2017/02/'> February 2017 </option>
	<option value='https://theeasterner.org/date/2017/01/'> January 2017 </option>
	<option value='https://theeasterner.org/date/2016/12/'> December 2016 </option>
	<option value='https://theeasterner.org/date/2016/11/'> November 2016 </option>
	<option value='https://theeasterner.org/date/2016/10/'> October 2016 </option>
	<option value='https://theeasterner.org/date/2016/09/'> September 2016 </option>
	<option value='https://theeasterner.org/date/2016/08/'> August 2016 </option>
	<option value='https://theeasterner.org/date/2016/06/'> June 2016 </option>
	<option value='https://theeasterner.org/date/2016/05/'> May 2016 </option>
	<option value='https://theeasterner.org/date/2016/04/'> April 2016 </option>
	<option value='https://theeasterner.org/date/2016/03/'> March 2016 </option>
	<option value='https://theeasterner.org/date/2016/02/'> February 2016 </option>
	<option value='https://theeasterner.org/date/2016/01/'> January 2016 </option>
	<option value='https://theeasterner.org/date/2015/12/'> December 2015 </option>
	<option value='https://theeasterner.org/date/2015/11/'> November 2015 </option>
	<option value='https://theeasterner.org/date/2015/10/'> October 2015 </option>
	<option value='https://theeasterner.org/date/2015/09/'> September 2015 </option>
	<option value='https://theeasterner.org/date/2015/06/'> June 2015 </option>
	<option value='https://theeasterner.org/date/2015/05/'> May 2015 </option>
	<option value='https://theeasterner.org/date/2015/04/'> April 2015 </option>
	<option value='https://theeasterner.org/date/2015/03/'> March 2015 </option>
	<option value='https://theeasterner.org/date/2015/02/'> February 2015 </option>
	<option value='https://theeasterner.org/date/2015/01/'> January 2015 </option>
	<option value='https://theeasterner.org/date/2014/12/'> December 2014 </option>
	<option value='https://theeasterner.org/date/2014/11/'> November 2014 </option>
	<option value='https://theeasterner.org/date/2014/10/'> October 2014 </option>
	<option value='https://theeasterner.org/date/2014/09/'> September 2014 </option>
	<option value='https://theeasterner.org/date/2014/08/'> August 2014 </option>
	<option value='https://theeasterner.org/date/2014/07/'> July 2014 </option>
	<option value='https://theeasterner.org/date/2014/06/'> June 2014 </option>
	<option value='https://theeasterner.org/date/2014/05/'> May 2014 </option>
	<option value='https://theeasterner.org/date/2014/04/'> April 2014 </option>
	<option value='https://theeasterner.org/date/2014/03/'> March 2014 </option>
	<option value='https://theeasterner.org/date/2014/02/'> February 2014 </option>
	<option value='https://theeasterner.org/date/2014/01/'> January 2014 </option>
	<option value='https://theeasterner.org/date/2013/12/'> December 2013 </option>
	<option value='https://theeasterner.org/date/2013/11/'> November 2013 </option>
	<option value='https://theeasterner.org/date/2013/10/'> October 2013 </option>
	<option value='https://theeasterner.org/date/2013/09/'> September 2013 </option>
	<option value='https://theeasterner.org/date/2013/08/'> August 2013 </option>
	<option value='https://theeasterner.org/date/2013/06/'> June 2013 </option>
	<option value='https://theeasterner.org/date/2013/05/'> May 2013 </option>
	<option value='https://theeasterner.org/date/2013/04/'> April 2013 </option>
	<option value='https://theeasterner.org/date/2013/03/'> March 2013 </option>
	<option value='https://theeasterner.org/date/2013/02/'> February 2013 </option>
	<option value='https://theeasterner.org/date/2013/01/'> January 2013 </option>
	<option value='https://theeasterner.org/date/2012/12/'> December 2012 </option>
	<option value='https://theeasterner.org/date/2012/11/'> November 2012 </option>
	<option value='https://theeasterner.org/date/2012/10/'> October 2012 </option>
	<option value='https://theeasterner.org/date/2012/09/'> September 2012 </option>

		</select>

<script type='text/javascript'>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-5" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</div><div class="widgetfooter3"></div></div></section><div class="snoadnetwork"><div class="widgetwrap"><h3>Advertisement</h3><div class="widgetbody3"><div class="advertisementwrap" style="float:none;margin:0px auto;max-width:300px"><!-- Begin PublicityClerks Zone 2529 -->
<script type="text/javascript">
(function() {
var pubc = document.createElement('script'); 
pubc.type = 'text/javascript'; 
pubc.async = true;
pubc.src = '//cdn.publicityclerks.com/core/ad2/9672/2529';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(pubc, s);
})();
</script>
<div id="pubclerks_2529"></div>
<!-- End PublicityClerks Zone 2529 --></div></div></div></div></div></div></div></div><div class="sno_teaserbar" id="sno_teaserbar"><div class="stb_nav"><div class="custom-navigation"><span class="flex-prev"><div class="stb_left"><div class="fa fa-angle-left"><div class="icon-hidden-text">Navigate Left</div></div></div></span></div></div><div id='stb-container' class='flexslider'><ul class="slides"><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/46555/sports/ewu-seeks-red-emption-in-home-opener/#photo'><img src='https://theeasterner.org/wp-content/uploads/2019/09/DSC_3236-e1567718066642-475x187.jpg' id='grow-stb46555'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Ready or not, here comes a Roos renovation'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb46555').mouseenter(function() {
   											jQuery('#grow-stb46555').removeClass('shrink');
   											jQuery('#grow-stb46555').removeClass('grow');
   											jQuery('#grow-stb46555').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb46555').addClass('shrink');
   										});});</script><p class='stb-cat'>Football</p><p class="relatedtitle"><a href="https://theeasterner.org/46555/sports/ewu-seeks-red-emption-in-home-opener/">EWU seeks red-emption in home opener</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/46542/sports/football/eagles-thrashed-by-huskies-in-football-opener/#photo'><img src='https://theeasterner.org/wp-content/uploads/2019/08/MG_1128-475x317.jpg' id='grow-stb46542'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Ready or not, here comes a Roos renovation'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb46542').mouseenter(function() {
   											jQuery('#grow-stb46542').removeClass('shrink');
   											jQuery('#grow-stb46542').removeClass('grow');
   											jQuery('#grow-stb46542').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb46542').addClass('shrink');
   										});});</script><p class='stb-cat'>Football</p><p class="relatedtitle"><a href="https://theeasterner.org/46542/sports/football/eagles-thrashed-by-huskies-in-football-opener/">Eagles thrashed by Huskies in football opener</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/46527/carousel/eagles-fly-west-to-kick-off-season/#photo'><img src='https://theeasterner.org/wp-content/uploads/2018/10/43332344460_b5c86f31aa_o-1-475x317.jpg' id='grow-stb46527'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Ready or not, here comes a Roos renovation'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb46527').mouseenter(function() {
   											jQuery('#grow-stb46527').removeClass('shrink');
   											jQuery('#grow-stb46527').removeClass('grow');
   											jQuery('#grow-stb46527').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb46527').addClass('shrink');
   										});});</script><p class='stb-cat'>Football</p><p class="relatedtitle"><a href="https://theeasterner.org/46527/carousel/eagles-fly-west-to-kick-off-season/">Eagles fly west to kick off season</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/46521/carousel/two-football-players-shot-in-downtown-spokane/#photo'><img src='https://theeasterner.org/wp-content/uploads/2019/01/Section-Graphics_News-475x297.png' id='grow-stb46521'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Ready or not, here comes a Roos renovation'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb46521').mouseenter(function() {
   											jQuery('#grow-stb46521').removeClass('shrink');
   											jQuery('#grow-stb46521').removeClass('grow');
   											jQuery('#grow-stb46521').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb46521').addClass('shrink');
   										});});</script><p class='stb-cat'>Football</p><p class="relatedtitle"><a href="https://theeasterner.org/46521/carousel/two-football-players-shot-in-downtown-spokane/">Two EWU football players shot in downtown Spokane</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/46503/arts-entertainment-features/ewu-graduating-seniors-reflect-on-college/#photo'><img src='https://theeasterner.org/wp-content/uploads/2019/01/Section-Graphics_AF-475x297.png' id='grow-stb46503'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Ready or not, here comes a Roos renovation'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb46503').mouseenter(function() {
   											jQuery('#grow-stb46503').removeClass('shrink');
   											jQuery('#grow-stb46503').removeClass('grow');
   											jQuery('#grow-stb46503').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb46503').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Features</p><p class="relatedtitle"><a href="https://theeasterner.org/46503/arts-entertainment-features/ewu-graduating-seniors-reflect-on-college/">EWU graduating seniors reflect on college</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/46499/carousel/asewu-2019-in-review/#photo'><img src='https://theeasterner.org/wp-content/uploads/2019/06/IMG_2312-1-475x356.jpg' id='grow-stb46499'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Ready or not, here comes a Roos renovation'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb46499').mouseenter(function() {
   											jQuery('#grow-stb46499').removeClass('shrink');
   											jQuery('#grow-stb46499').removeClass('grow');
   											jQuery('#grow-stb46499').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb46499').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://theeasterner.org/46499/carousel/asewu-2019-in-review/">ASEWU: 2019 in review</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/46488/carousel/phi-delta-theta-fights-als/#photo'><img src='https://theeasterner.org/wp-content/uploads/2019/06/Image-28-475x353.jpg' id='grow-stb46488'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Ready or not, here comes a Roos renovation'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb46488').mouseenter(function() {
   											jQuery('#grow-stb46488').removeClass('shrink');
   											jQuery('#grow-stb46488').removeClass('grow');
   											jQuery('#grow-stb46488').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb46488').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://theeasterner.org/46488/carousel/phi-delta-theta-fights-als/">Phi Delta Theta fights ALS</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/46481/arts-entertainment-features/heber-hatch-axe-throwing-opens-in-spokane/#photo'><img src='https://theeasterner.org/wp-content/uploads/2019/06/MG_9388-475x317.jpg' id='grow-stb46481'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Ready or not, here comes a Roos renovation'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb46481').mouseenter(function() {
   											jQuery('#grow-stb46481').removeClass('shrink');
   											jQuery('#grow-stb46481').removeClass('grow');
   											jQuery('#grow-stb46481').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb46481').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Features</p><p class="relatedtitle"><a href="https://theeasterner.org/46481/arts-entertainment-features/heber-hatch-axe-throwing-opens-in-spokane/">Heber Hatchets Axe Throwing opens in Spokane</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/46436/2018-19-eags-of-the-year/student-athlete-of-the-year-dehonta-hayes/#photo'><img src='https://theeasterner.org/wp-content/uploads/2019/06/MG_9610-475x317.jpg' id='grow-stb46436'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Ready or not, here comes a Roos renovation'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb46436').mouseenter(function() {
   											jQuery('#grow-stb46436').removeClass('shrink');
   											jQuery('#grow-stb46436').removeClass('grow');
   											jQuery('#grow-stb46436').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb46436').addClass('shrink');
   										});});</script><p class='stb-cat'>2018-19 Eags of the Year</p><p class="relatedtitle"><a href="https://theeasterner.org/46436/2018-19-eags-of-the-year/student-athlete-of-the-year-dehonta-hayes/">Student-athlete of the year: Dehonta Hayes</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://theeasterner.org/46435/2018-19-eags-of-the-year/scholar-of-the-year-jordan-stevenson/#photo'><img src='https://theeasterner.org/wp-content/uploads/2019/06/MG_9528-317x475.jpg' id='grow-stb46435'  style='width:70px;min-width:70px;' class='catboxphoto' alt='Ready or not, here comes a Roos renovation'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb46435').mouseenter(function() {
   											jQuery('#grow-stb46435').removeClass('shrink');
   											jQuery('#grow-stb46435').removeClass('grow');
   											jQuery('#grow-stb46435').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb46435').addClass('shrink');
   										});});</script><p class='stb-cat'>2018-19 Eags of the Year</p><p class="relatedtitle"><a href="https://theeasterner.org/46435/2018-19-eags-of-the-year/scholar-of-the-year-jordan-stevenson/">Scholar of the year: Jordan Stevenson</a></p></li></ul></div><div class="stb_nav"><div class="custom-navigation"><span class="flex-next"><div class="stb_right"><div class="fa fa-angle-right"><div class="icon-hidden-text">Navigate Right</div></div></div></span></div></div></div><div class="clear"></div><script type="text/javascript" charset="utf-8">
		jQuery(document).ready(function() {
			jQuery('#stb-container').flexslider({
				animation: "slide",
				animationLoop: true,
				customDirectionNav: jQuery(".stb_nav .custom-navigation span"), 
       			slideshow: false,
				itemMargin: 2,
				touch: true,
				itemWidth: 250,
				minItems: 1,
				move: 1,
				maxItems: 5
  			});

  							//		animation: 'fade',
  							//		smoothHeight: false,
  							//		customDirectionNav: jQuery("#sfi-navigation span"),
  							//		animationLoop: true,
  							//		slideshow: false,
  							//		touch: true



		});

			jQuery(document).ready(function(){
			
			var TB_CurrentScroll = 0; var TB_NextScroll = 0; var hbheight = 0;
			
			
			jQuery(window).scroll(function(event) {
				TB_CurrentScroll = TB_NextScroll;
				if (jQuery('#sno_hoverbar').is(":visible")) { hbheight = 50 }
				TB_NextScroll = jQuery(this).scrollTop();
				if (TB_NextScroll < TB_CurrentScroll && jQuery(document).scrollTop() > 500) {  // scrolling up on the page causes it to display
					if (jQuery('.sno_teaserbar').is(":hidden")) {
						jQuery('.sno_teaserbar').show();
						jQuery('.sno_teaserbar').stop().animate({ top: hbheight }, { duration: 300, queue: false });
					}
				}
				 else if ((TB_NextScroll > TB_CurrentScroll && jQuery(document).scrollTop() > 500) || jQuery(document).scrollTop() < 400 ){ // scrolling down on the page causes it to hide
					jQuery('.sno_teaserbar').stop().animate({
						top: '-86px'
						},200, function(){
							jQuery('.sno_teaserbar').hide();
						});
				} 
			});
				});
	</script></div></div></div><div style="clear:both;"></div><div class="footeradboardwrap">
	<div id="footeradboard">
	<div class="footeradboardadwrap" style="margin:0px auto;float:none;">
	<a target="_blank" href="https://theeasterner.org/advertising/"><img src="https://theeasterner.org/wp-content/uploads/2018/10/728x90-hq.jpg" /></a>	 </div>
	 
	 	
	</div>
</div>
<div class="footerwrap"><div id="footer"><div class="footername"><div class="footerleft"><p><a href="https://theeasterner.org">The Easterner</a></p></div></div><div class="footertagline"><p>The independent, student-run news site of Eastern Washington University.</p></div><div class="footersearch">	<form method="get" id="searchform7703" action="https://theeasterner.org/">
			<div class="search-button-container" id="searchthis7703">
			<button type="submit" disabled="disabled" id="sno-search-navbar-7703" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s7703" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s7703" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit7703" style="display:none;" value="Search" />
		</form>
	</div><div class="clear"></div><div class="footermenu"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-37720" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37720"><a href="https://theeasterner.org/about/">About The Easterner</a></li>
<li id="menu-item-37721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37721"><a href="https://theeasterner.org/about/contact-us/">Contact Us</a></li>
</ul></div></div><div class="footercredit"><p><a href="http://www.easterneronline.com">The Easterner</a> &bull; &copy; 2019  &bull; <a target='_blank' href='/'>Privacy Policy</a> &bull; <a href='https://snosites.com/why-sno/'>FLEX WordPress Theme</a> by <a href='http://snosites.com'>SNO</a> &bull; <a rel="nofollow" href="https://theeasterner.org/wp-login.php">Log in</a></p></div><div class="clear"></div></div></div><script type="text/javascript">
jQuery(window).load(function() {
	jQuery('.flexslider').animate({'opacity': 1}, { 'duration': 'slow'});
	jQuery('.flex-container').css('background', 'unset');
});

</script><script type="text/javascript">
// start of scroll to view


jQuery(document).ready(function() {
	
	jQuery("a[href='#slideshow']").on('click', function(event) { return false; });
	jQuery("a[href='#photo']").on('click', function(event) { return false; });

var win = jQuery(window);
var allMods = jQuery(".sno-animate");
var allWPcaptions = jQuery(".wp-caption");

// Already visible modules
allMods.each(function(i, el) {
  var el = jQuery(el);
  if (el.visible(true)) {
    el.addClass("already-visible"); 
  } 
else {
  /*  Like this!  */
  el.css('visibility', 'hidden');
  }
});
allWPcaptions.each(function(i, el) {
  var el = jQuery(el);
  if (el.visible(true)) {
    el.addClass("already-visible"); 
  } 
});


jQuery(window).scroll(function(event) {
  
  jQuery(".sno-animate").each(function(i, el) {
    var el = jQuery(el);
    if (el.visible(true)) {
      	el.addClass("come-in");     
	    el.css('visibility', 'visible'); // Visible
    } 
  });
  jQuery(".wp-caption").each(function(i, el) {
    var el = jQuery(el);
    if (el.visible(true)) {
      	el.addClass("come-in");     
	    el.css('visibility', 'visible'); // Visible
    } 
  });
  
});


});
//end of scroll to view
</script>
<script type="text/javascript">
	
	jQuery(document).ready(function(){
		// jQuery(".wp-caption").removeAttr('style');
		jQuery.each(jQuery(".wp-caption"), function(){
			jQuery(this).width(jQuery(this).find('img').attr('width'));
		});
	})
	jQuery(function(){
		jQuery(".s").focus(function(){
			jQuery(".sno-submit-search-button").prop("disabled", false);
		});				
	});
    var top_level_links = jQuery(".sf-menu").find('> li > a');
    // Set tabIndex to -1 so that top_level_links can't receive focus until menu is open
    jQuery(top_level_links).next('ul')
      //  .attr({ 'aria-hidden': 'true', 'role': 'menu' })
	  	.attr({ 'role': 'menu' })
        .find('a')
            .attr('tabIndex',-1);

    // Adding aria-haspopup for appropriate items
    jQuery(top_level_links).each(function(){
        if(jQuery(this).next('ul').length > 0)
            jQuery(this).parent('li').attr('aria-haspopup', 'true');
    });
   
jQuery( function() {
 	jQuery( '#hover-menu-side' ).on( 'touchstart click', function(e) {
 		e.preventDefault();
 			jQuery('#sno_mobile_menu').fadeToggle();
		    jQuery("body").toggleClass('noscroll');

 	});
 	jQuery( '.side-close-icon' ).on( 'touchstart click', function(e) {
 		e.preventDefault();
 			jQuery('#sno_mobile_menu').fadeToggle();
			    jQuery("body").toggleClass('noscroll');
 	});
 		
});

</script>
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-53299197-5', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
		
	      <script type="text/javascript">

          var pfHeaderImgUrl = '';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '0';
          var pfImagesSize = 'full-size';
          var pfImageDisplayStyle = 'right';
          var pfEncodeImages = '0';
          var pfDisableEmail = '0';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
          var pfPlatform = 'Wordpress';
      </script>
      <script async src='https://cdn.printfriendly.com/printfriendly.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/theeasterner.org\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://theeasterner.org/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/theeasterner.org\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://theeasterner.org/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.2'></script>
<script type='text/javascript' src='https://theeasterner.org/wp-includes/js/wp-embed.min.js?ver=5.2.3'></script>
</div><div id="sno_hoversearch"><div class="sno-search-close foundation-icons fi-x" style="float:right;"></div><div class="hover-search-area"><form method="get" id="searchform-alt" action="https://theeasterner.org/">
											<label for="s-alt" class="assistive-text">Search</label>
											<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
											<input type="submit" class="submit" name="submit" id="searchsubmit-alt" value="Search" />
											<button type="submit" id="sno-hover-search-button" class="sno-submit-search sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
										</form></div></div><div id="sno_hoverbar"><div class="hoverheader"><div id="search-top"><div class="sno-search-button fa fa-search"><span class="icon-hidden-text">Activate Search</span></div></div><div class="socialmedia"><script type="text/javascript">
					jQuery(function () {
						jQuery('.commentscroll').click(function () {
						var adjustment = 70;
																			adjustment += jQuery('.subnavbarwrap').height();
												jQuery('html, body').animate({ scrollTop: jQuery("#commentswrap").offset().top - adjustment }, 500);
						return false;
						});
					});
				</script><div class="sharing sharing-top"><a class='commentscroll' href='https://theeasterner.org/46578/carousel/ready-or-not-here-comes-a-roos-renovation/#respond'><div class='sharing-icon sno-comments fa fa-comments-o sno-dark  sharing-mobile-hide'></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ftheeasterner.org%2F46578%2Fcarousel%2Fready-or-not-here-comes-a-roos-renovation%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Ready+or+not%2C+here+comes+a+Roos+renovation&amp;url=https%3A%2F%2Ftheeasterner.org%2F%3Fp%3D46578" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a data-remodal-target="modal"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a></div>			<script type="text/javascript">
				jQuery(document).ready(function() {
					jQuery(function($){
						$('.modal-share').click(function() {
							var inst = $('[data-remodal-id=modal-share]').remodal();
							inst.open();

							var sharestoryid = '46578';

							$.ajax({
	                			url:"/wp-admin/admin-ajax.php",
								type:'POST',
								data:'action=sharestory&sharestoryid=' + sharestoryid,
								success:function(results)
	            					{ $(".suggestedstories").replaceWith(results); }
	           				});

						});
										
					});
				});
			</script>

			<div class="remodal" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div class="suggestedstories">
  				<h1>Hang on for a minute...we're trying to find some more stories you might like.</h1>
  				<form method="post" action="">

  				<br />
  				<button data-remodal-action="cancel" class="remodal-cancel">Close</button>

  				</form>
  				</div>
			</div>

					<div class="remodal" data-remodal-id="modal" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div class="emailstoryform">
  				<h1>Email This Story</h1>
  				<form method="post" action="">
  				<label for="email_to_Bar" style="display:none;">Send email to this address</label>
  				<input type="text" id="email_to_Bar" name="email_to_Bar" class="sno_email_fields" placeholder="Send email to this address"><br />
  				
  				<label for="email_from_Bar" style="display:none;">Enter Your Name</label>
  				<input type="text" id="email_from_Bar" name="email_from_Bar" class="sno_email_fields" placeholder="Enter Your Name"><br />
  				
  				<label for="email_comment_Bar" style="display:none;">Add a comment here</label>
  				<textarea rows="4" id="email_comment_Bar" name="email_comment_Bar" class="sno_email_fields" placeholder="Add a comment here (optional)."></textarea><br />
  				
  				<label for="human_Bar" style="display:none;">Verification</label>
  				<input type="text" id="human_Bar" name="human_Bar" class="sno_email_fields" placeholder="What's 5 + 5?"><br />

  				<br />
  				<button id="submit_email_Bar" data-remodal-action="confirm" class="remodal-confirm">Send Email</button>
  				<button data-remodal-action="cancel" class="remodal-cancel">Cancel</button>
  				<input type="hidden" id="sno_email_submission_form557031" name="sno_email_submission_form557031" value="3c606f8c94" /><input type="hidden" name="_wp_http_referer" value="/46578/carousel/ready-or-not-here-comes-a-roos-renovation/" />
  				</form>
  				</div>
			</div>
										<script>
								jQuery(document).ready(function() {

								jQuery(function($){
           							$('#submit_email_Bar').click(function(){
											var storyid = '46578';
											var datastring = '';
											if ($("#email_to_Bar").length > 0){
												var email_to = $('input[name=email_to_Bar]');
												datastring += '&email_to=' + encodeURIComponent(email_to.val());
       										}

											if ($("#email_from_Bar").length > 0){
												var email_from = $('input[name=email_from_Bar]');
												datastring += '&email_from=' + encodeURIComponent(email_from.val());
       										}

											if ($("#email_comment_Bar").length > 0){
												var email_comment = $('textarea[name=email_comment_Bar]');
												datastring += '&email_comment=' + encodeURIComponent(email_comment.val());
       										}

											if ($("#human_Bar").length > 0){
												var human = $('input[name=human_Bar]');
												datastring += '&human=' + encodeURIComponent(human.val());
       										}
       										
	   										datastring += '&humanity=' + 10;

       										var verification = $('input[name=sno_email_submission_form557031]');
	   										datastring += '&verification=' + verification.val();
       										
										//	var parentid = '';
               							$.ajax({
                				            url:"/wp-admin/admin-ajax.php",
                				            type:'POST',
                				            data:'action=emailstory&storyid=' + storyid + datastring,
 	            				            success:function(results)
	            				            { $(".emailstoryform").replaceWith(results); }
	           				    	  	});
	         						});
								});
								});

							</script>

			</div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div class="sno-arrow-up fa fa-arrow-up"><span class="icon-hidden-text">Scroll to Top</span></div></a></div><div class="lf_headerleft"><a href="/"><img src="/wp-content/uploads/2018/09/85510_Header-01.jpg" alt="The independent, student-run news site of Eastern Washington University." /></a></div><div class="hover_title"><div class="hover_titletext">Ready or not, here comes a Roos renovation</div><span id="progress-bar"><span id="progress-bar-color"></span></span></div></div><div class="clear"></div></div><div id="hoverbar_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search"><form method="get" class="searchform-alt-left" action="https://theeasterner.org/">
									<label for="s-alt-left-hoverbar" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left-hoverbar" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-main-navigation-2" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-176"><a href="https://theeasterner.org/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43567"><a href="https://theeasterner.org/category/news/police-beat/">Police Beat</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43947"><a href="https://theeasterner.org/category/election-guide-2018/">Election Guide 2018</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38612"><a href="https://theeasterner.org/category/arts-entertainment-features/">A&#038;F</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-37719"><a href="https://theeasterner.org/category/sports/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46074"><a href="https://theeasterner.org/category/sports/basketball/">Basketball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-46075"><a href="https://theeasterner.org/category/sports/football/">Football</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46076"><a href="https://theeasterner.org/category/sports/track-and-field/">Track and field</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-177"><a href="https://theeasterner.org/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43561"><a href="https://theeasterner.org/category/opinion/easterner-asks/">Easterner asks</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46077"><a href="https://theeasterner.org/category/opinion/letters-to-the-editor/">Letters To The Editor</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43207"><a href="https://theeasterner.org/category/editorial/">Editorial</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-38813"><a href="https://theeasterner.org/category/multimedia/">Multimedia</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45092"><a href="https://theeasterner.org/category/multimedia/looking-back/">Looking Back</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43211"><a href="https://theeasterner.org/category/multimedia/slideshow/">Slideshow</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43216"><a href="https://theeasterner.org/category/multimedia/audio/">Audio</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46453"><a href="https://theeasterner.org/category/2018-19-eags-of-the-year/">2018-19 Eags of the Year</a></li>
</ul></div></ul></div><script type="text/javascript">
		jQuery(document).ready(function(){
			

			function sharingIconsResize() {
				if (jQuery(window).width() < 850) {
					var socialwidth;
					var count = jQuery("#mobile-socialmedia .sharing-mobile-show").length;
					if (count != 0) {
						socialwidth = 100 / count;
						jQuery('#mobile-socialmedia .sharing-icon').width(socialwidth + '%');
					}
				} else {
					jQuery('#sno_hoverbar .sharing-icon').width('50px');
				}
			}
						
			jQuery('.sno-search-button').click(function() {
				jQuery('#sno_hoversearch').fadeToggle();
				jQuery('#sno_hoversearch').css({ top: '0' });
				jQuery('#s-alt').focus();
			});
			jQuery('.sno-search-close').click(function() {
				jQuery('#sno_hoversearch').fadeToggle();
				jQuery('#sno_hoversearch').css({ top: '-50px' });
			});

			var NavScrollTop		= jQuery(window).scrollTop();
    		
    		if( jQuery('.navbarwrap').length ) {
    			var	TopNavOffset 		= jQuery('.navbarwrap').offset().top;
				var TopNavDistance		= (TopNavOffset - NavScrollTop);
   	 		}
   	 		if( jQuery('.subnavbarwrap').length ) {
	   	 		var	BottomNavOffset 	= jQuery('.subnavbarwrap').offset().top;
	   	 		var	BottomNavDistance	= (BottomNavOffset - NavScrollTop);
   	 		}
   	 		
   	 		jQuery('#hoverbar_menu .mobile-menu').height( jQuery(window).height() - 50);
   	 		
   	 		var HoverOffset = 0, HoverOffset2 = 0;
			   	 		var HoverHeight = jQuery('#sno_hoverbar').outerHeight();
   	 		var HoverHeight2 = jQuery('#sno_hoverbar').outerHeight();
   	 		
			
			var CurrentScroll = 0;
			var WindowHeight = jQuery(document).height() - jQuery('.footerwrap').height();
			
							WindowHeight -= jQuery('#commentswrap').height();		
						
			
			jQuery('.sno-menu').click(function() {
			
				jQuery('#hoverbar_menu').fadeToggle();
				jQuery('.menu-icon').toggle();
				jQuery('.close-icon').toggle();
				jQuery('#hoverbar_menu').css({ height: jQuery(window).height() - 50 });
			
			});
			
			jQuery(window).scroll(function(event) {
				var NextScroll = jQuery(this).scrollTop();

				var ScrollPercent = (NextScroll / (WindowHeight - jQuery(window).height())) * 100;
				

				jQuery('#progress-bar-color').css({ width: ScrollPercent + '%'});
				jQuery('#hoverbar_menu').css({ top: jQuery('#sno_hoverbar').height() });
				
				if ( ScrollPercent > 100 ) {
										jQuery('.sno-arrow-up').css({ background: '#ca2a1d', color: '#eee'});
					jQuery('.sno-menu').css({ background: '#ca2a1d', color: '#eee'});
					jQuery('.socialmedia .sharing-icon').css({ opacity: 1 })
					
					
				} else {
										jQuery('.sno-arrow-up').css({ background: '#eee', color: '#ccc'});
					jQuery('.sno-menu').css({ background: '#eee', color: '#ccc'});
				}
				var headerLocation = jQuery("#wrap").offset().top;
				if (NextScroll > CurrentScroll && jQuery(document).scrollTop() > headerLocation) {
					if (jQuery('#sno_hoverbar').is(":hidden")) {
						jQuery('#sno_hoverbar').show();
						jQuery('#sno_hoverbar').stop().animate({ top: '0' }, { duration: 300, queue: false });
						
													if( jQuery('.subnavbarwrap').length ) {	
								jQuery('.subnavbarwrap').stop().animate({ top: HoverHeight2 +'px'}, { duration: 300, queue: false });
							}
												
													var lpb = jQuery('.lf_headerleft').width();
														var rpb = 50 + jQuery('.socialmedia').width();
															rpb += jQuery('#sno_hoverbar .sno-search-button').width();
														jQuery('#progress-bar').css({ left: lpb + 'px', right: rpb + 'px'})
						        			}


        			
				} else if (NextScroll < CurrentScroll && jQuery(document).scrollTop() < ( headerLocation + 300 ) && jQuery('#sno_hoverbar').is(":visible")) {
				
						jQuery('#hoverbar_menu').hide();
						jQuery('.close-icon').hide();
						jQuery('.menu-icon').show();
						jQuery('#hoverbar_menu').hide();
						jQuery('#sno_hoverbar').stop().animate({
							top: '-50px'
							},300, function(){
								jQuery('#sno_hoverbar').hide();
							});
						if ( jQuery('.navbarwrap').length ) { jQuery('.navbarwrap').stop().animate({ top: HoverOffset + 'px'},300); }
						if ( jQuery('.subnavbarwrap').length ) { jQuery('.subnavbarwrap').stop().animate({ top: HoverOffset2 + 'px'},300); }

				}
			CurrentScroll = NextScroll;
			});


		});

		jQuery("#snotop").hide();
	
		jQuery(function () {
			jQuery(window).scroll(function () {
				if (jQuery(this).scrollTop() > 500) {
					jQuery('#snotop').fadeIn();
				} else {
					jQuery('#snotop').fadeOut();
				}
			});

			jQuery('#back-top a').click(function () {
				jQuery('body,html').animate({
					scrollTop: 0
				}, 800);
				return false;
			});

		});
	</script></body></html>